Legacy Product Discussions

Filerview snapshots schedule not working

sergenet

filerview ver. 7.2  When I schedule a snapshot it does not do anything. It used to be ok and for the past couple of months it refuses to work. I can do a manual snapshot under storevault manager but not according to a schedule. Please let me know why I am not able to schedule snapshots. Thank you.

6 REPLIES 6

Filerview snapshots schedule not working

sergenet

doesn't anybody have any idea on how to proceed withthis problem?

Filerview snapshots schedule not working

paleon

I hardly ever use filerview, so I cannot speak to why filerview might not be working correctly.  If you would like help configuring the snapshots from the command line, I'd be more than happy to provide some suggestions.  Are you using SnapVault snapshots or ordinary volume snapshots?  The commands and their syntaxes are different.  Also, if you are using SnapVault snapshots on a volume, best practices recommend that you disable ordinary snapshots on that volume.

Re: Filerview snapshots schedule not working

sergenet

Thanks for your reply paleon. I really do not know the difference between SnapVault snapshots and ordinary snapshots. How can I tell? I will  try to insert an image of what I do to get a manual snapshot since the schedule is not working. I am unable to insert image. Keep getting error.

Re: Filerview snapshots schedule not working

paleon

Ordinary volume snapshots are configured with the "snap sched" command.  Snapshots made this way are named "weekly.#", "nightly.#", or "hourly.#", where # is a non-negative integer starting with 0.

The syntax for configuring ordinary snapshots is:

snap sched [volname [W N H[@h,h,h,h]]]

W = the number of weekly snapshots to retain
N = the number of daily snapshots to retain

H = the number of hourly snapshots to retain

@h,h,h,h = an optional parameter for specifying at which hours the hourly snapshots should be taken.  The "h,h,h,h" is a comma list of hours at which to creat the snapshots.

So, to configure a volume named vol1 to retain 8 weeks of weekly snapshots, 14 nightly, and 0 hourly snapshots, the command is:

snap sched vol1 8 14 0

To configure a volume named vol2 to retain 4 weekly snapshots, 7 nightly snapshots, and 6 hourly snapshots taken at 6 a.m., 12 noon, and 6 p.m. each day, the command is:

snap sched vol2 4 7 6@6,12,18

Please bear in mind that weekly snapshots have a higher priority than nightly snapshots and that nightly snapshots have a higher priority than hourly snapshots.  As a result, at 00:00 on Sunday night, a volume which is configured to create both weekly and nightly snapshots will create a weekly snapshot but not a nightly snapshot.

If you want to check a volume's snapshot schedule, you can type:

snap sched [volname]

If no volume is specified, you will see the snapshot schedules for all volumes on that controller.

SnapVault snapshots are a bit more complicated to explain.  Do you use SnapVault on your filers?

Bill

View solution in original post

Re: Filerview snapshots schedule not working

paleon

For more information, you can type "man snap" on the command line to read the manual page for the "snap" command, which will include "snap sched".

Re: Filerview snapshots schedule not working

sergenet

Thank you, Bill. It is working now. There is a schedule for weekly, daily and hourly which works now and then but not all the time. For now it is working.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public