Legacy Product Discussions

Highlighted

snapdrive 6.1 in VM timeouts when connecting to existing luns

Using ESX 3.5Update 4 I installed 6.1 SD in a windows 2003SP2 (iSCSI). All hotfixes have been added. I can create luns with no problems but everytime I try to connect to an existing lun, snapdrive gives me timeout error after 120 seconds. Deatils box show all steps working except connecting to LUN. When I look on the filer side, LUN shows connected and online.

SD 6.1

all hotfixes installed

host utility kit installed

10 REPLIES 10
Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

Hi Steve,

Are you able to disconnect and connect back to the luns created through

SDW?

Thanks

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

Yes, I can disconnect and reconnect my LUNS created by snapdrive.

Steve Hannah

Netapp

System Engineer

408 822-6542 wk

408 888-0405 cell

steve.hannah@netapp.com

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

I think your disk connects were failing because luns were created from filerview and unformatted and not ready for use by the Windows OS.

I suggest that you create/disconnect/connect disks through SDW. SDW will take care of choosing the right lun type, formatting, assigning drive letter among other things.

Thanks

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

I repeated the process by:

-creating a lun in filerview

-attaching lun, formatting and partitioning. Also created test file

-unmapped and tried to connect via snapdrive and got same error, see attached.

I agree the luns need to be created via snapdrive but for my customer, they have existing luns they

Want to detach and connect via snapdrive.

STeve

Steve Hannah

Netapp

System Engineer

408 822-6542 wk

408 888-0405 cell

steve.hannah@netapp.com

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

- Are you using the correct lun type? You can verify this by checking the lun type created by SDW.

- Once you map the lun created outside of SDW & format manually, do you see the same through SDW?

Thanks,

~Satish

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

- Are you using the correct lun type? You can verify this by checking the lun type created by SDW.

LUN types are different. Good one is GPT and filerview created is MBR. From what I have read, MBR is not supported for windows 2003SP2, is that correct?

- Once you map the lun created outside of SDW & format manually, do you see the same through SDW?

I formatted the lun I created outside SDW manually. New disk acts normally in computer manager but still shows

MBR.

1. Is MBR my problem? If so, I have no idea how to convert to GPT.

2. I'm assuming I can disconnect a windows LUN with data and reconnect via SD and still see my data.

3. Once lun outside SD is displayed in SD, I disconnect and try reconnect with same issue

You seem to have found my problem but I don't know how to resolve the issue.

Steve Hannah

Netapp

System Engineer

408 822-6542 wk

408 888-0405 cell

steve.hannah@netapp.com

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

While creating the lun on the filer, the lun type to be chosen is "Windows-GPT".

Also, on the disk management window, you will find an option to covert type from MBR to GPT.

I tried out these steps and it worked for me.

- Create Lun on Filer of type "Windows-GPT".

- Map Lun to the SDW host.

- Rescan on the disk management on the host ( Don't convert to dynamic disk, retain as basic on the wizard )

- Convert to GPT. You get this option when you right click on the unformatted disk.

- Format the disk and assign drive letter.

- Able to see this disk from SDW and disconnect and connect.

I suppose you are using MS ISCSI to connect.

Thanks,

~Satish

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

I tried this on 7.3.1.1 where I can specify windows GPT and it seems to work (I'm having other issues but I will sort that out later).

At this point, my only question is how do we handle customers with existing LUNs that were created with MBR?

steve

Steve Hannah

Netapp

System Engineer

408 822-6542 wk

408 888-0405 cell

steve.hannah@netapp.com

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

A note from the SDW IAG

Neither SnapDrive nor Data ONTAP support MBR LUNs that are converted to GPT-style LUNs. If

you have an existing MBR-style LUN, rather than converting, you must create a new GPT LUN using

SnapDrive, then copy all the data from the MBR LUN to the GPT LUN.

Hope this helps

Highlighted

Re: snapdrive 6.1 in VM timeouts when connecting to existing luns

Thanks, that’s what I was looking for.

Steve Hannah

Netapp

System Engineer

408 822-6542 wk

408 888-0405 cell

steve.hannah@netapp.com

Check out the KB!
NetApp Insights To Action
All Community Forums