Microsoft Virtualization Discussions

Get-NaStorageAdapterInfo for onboard ports fails with xml error

skellner_fi

I try to gather the WWPN for onboard initiators and get the following error:

PS D:\Powershell> get-nastorageadapterinfo 0a

Get-NaStorageAdapterInfo : Fehler im XML-Dokument (1,544).

Bei Zeile:1 Zeichen:25

+ get-nastorageadapterinfo <<<<  0a

    + CategoryInfo          : InvalidOperation: (d100bplc017.d100.intern:NaController) [Get-NaStorageAdapterInfo], Inv

   alidOperationException

    + FullyQualifiedErrorId : ApiException,DataONTAP.PowerShell.SDK.Cmdlets.StorageAdapter.GetNaStorageAdapterInfo

PS D:\Powershell> get-nastorageadapterinfo 4a

AdapterDetailInfo

-----------------

DataONTAP.Types.StorageAdapter.AdapterDetailInfo

Expansion Adapters are working. I already installed the V3.0 of the toolkit. However, the error stays the same.

Does anybody know a solution or workaround for this?

2 REPLIES 2

beam

You can workaround this by using Invoke-NaSystemApi.  For example:

[3.0] 10.61.167.86> $adapterName = "0a"

[3.0] 10.61.167.86> $xml = "<storage-adapter-get-adapter-info><adapter-name>$adapterName</adapter-name></storage-adapter

-get-adapter-info>"

[3.0] 10.61.167.86> $result = Invoke-NaSystemApi $xml

[3.0] 10.61.167.86> $result

results

-------

results

You can discover the fields contained in the results like this:

[3.0] 10.61.167.86> $result.results

status                                                      adapter-details

------                                                      ---------------

passed                                                      adapter-details

[3.0] 10.61.167.86> $result.results.'adapter-details'

adapter-detail-info

-------------------

adapter-detail-info

[3.0] 10.61.167.86> $result.results.'adapter-details'.'adapter-detail-info'

adapter-name                            adapter-type                            adapter-sas

------------                            ------------                            -----------

0a                                      ADT_IF_SAS                              adapter-sas

If you don't mind, can you post the result XML (or if you prefer you can send it to me in a message) so we can debug the deserialization and hopefully get a fix into the Toolkit?

[3.0] 10.61.167.86> $result.OuterXml

Thanks!

Steven

skellner_fi

Hi Steven,

sorry it took a while. Here is the xml:

PS D:\WFA\Systemkonfiguration> $result.outerxml

<results status="passed"><adapter-details><adapter-detail-info><adapter-name>0a</adapter-name><adapter-type>ADT_IF_FC</adapter-type><adapter-fc><adapter-fc-info><adapter-model>QLogic 2532</adapter-model><hard

ware-rev>2</hardware-rev><firmware-rev>5.4.130</firmware-rev><fc-node-name>5:00a:098001:fdb640</fc-node-name><fc-packet-size>2048</fc-packet-size><fc-link-rate>8</fc-link-rate><is-ext-gbic>false</is-ext-gbic>

<is-enabled>true</is-enabled><is-in-use>false</is-in-use><is-redundant>true</is-redundant><host-port-id>0x12e00</host-port-id><adapter-bar><adapter-bar-info><bar-type>I/O</bar-type><bar-base>0</bar-base><bar-

size>256</bar-size></adapter-bar-info><adapter-bar-info><bar-type>memory mapped I/O</bar-type><bar-base>3707764736</bar-base><bar-size>16384</bar-size></adapter-bar-info></adapter-bar><adapter-sfp-info><vendo

r>AVAGO</vendor><part-number>AFBR-57D7AMZ</part-number><serial-number>AA1323A3TY4</serial-number><speed-capabilities>2, 4, 8 Gbit/Sec</speed-capabilities></adapter-sfp-info></adapter-fc-info></adapter-fc></ad

apter-detail-info></adapter-details></results>

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public