Subscribe

Re: Resizing a LUN to 90% of Flex Volume

OK so de-duplication is enabled for the volume; I think it explains it. First, it works by creating temporary snapshot during dedup run; second, de-duplication by definition cannot predict how much free space will be available, so it could be treated like snapshot w.r.t. to LUN reservation (anyone to comment here?)

You could set fractional reserve to 0 to remove reservation; it is up to you to decide whether you actually want it.

Re: Resizing a LUN to 90% of Flex Volume

OK, but what is the fractional reserve used for?

I would think that dedupe would save me space, not consume it.

Re: Resizing a LUN to 90% of Flex Volume

In 7.3.2, you have to set the fractional reserve to 100 before you can set the volume guarantee to none.  At this point, the volume is thin provisioned (could be overcommitted), however fully space reserved LUNs inside the volume still follow the same creation rules as in a thick volume (LUN size + fractional reserve can't exceed declared volume size).  SInce with the guarantee set to none the volume is already thin provisioned, you could simply overcommit the volume by growing it then grow your LUN.  You could also consider removing the space reserve for the LUN.

in 7.3.3, you're not required to set the fractional reserve to 100% before setting the volume guarantee to none.  You could always upgrade to 7.3.3 as well.

In short at the volume level consider the frational reserve and the volume guarantee.  At the LUN level, consider the LUN space reserve.  If you'd like to experiment with the settings, the easy way is via powershell.

http://communities.netapp.com/docs/DOC-6400

http://communities.netapp.com/docs/DOC-6383

J

Re: Resizing a LUN to 90% of Flex Volume

Well, NetApp has many features; sometimes combining them may have unforeseen consequences.

I just tested in simulator. As soon as A-SIS is enabled for a volume, it reserves space for a LUN in this volume according to fractional_reserve setting. As I believe was already mentioned, to be able to set fractional_reserve=0 and guarantee=none you need 7.3.4.

I can understand why it behaves this way; if you want official answer, open a case with support and ask them to explain this behavior.

Re: Resizing a LUN to 90% of Flex Volume

Well, to me one thing is still unclear - the fact that the volume guarantee is set to none normally 'disables' fractional reserve, i.e. it should behave like set to 0.

That is not the case here apparently...

Re: Resizing a LUN to 90% of Flex Volume

Well, I would rather consider it a bug if I wanted to have 100 fractional reserve and it were silently ignored.

Volume guarantee none means I do not want to reserve full volume size upfront. But it does not mean that I do not want to ensure my LUN is still writable – it is just that now this space is reserved from parent aggregate and thus is shared among LUNs from multiple volumes.

If I truly wanted to ignore possible aggregate space overflow, I’d just set fractional_reserve=0 in the first place. That it was not possible was a bug (or, rather, misfeature) that was fixed.

Re: Resizing a LUN to 90% of Flex Volume

Well, I would rather consider it a bug if I wanted to have 100 fractional reserve and it were silently ignored.

Tricky issue, indeed. I always treated this as a 'handy' bug, because prior to 7.3.3 whenever I set volume guarantee to none, FR was locked at 100% & actually I didn't want FR to be anything else than 0%. But it behaved like 0%, so all was fine for me (although this is very untidy).