Network Storage Protocols Discussions

Get the proper Group & Owner from Netapp (using autofs, sssd)

tbeaudry

Hi,

I have a NAS (netapp). with a windows file server that has samba shares connect to AD.

I would like to mount some shares from the NAS onto my ubuntu 16.04 server. When I mount them, I get the group and owner listed as root. I would like to get the proper group and usernames that are listed on the NAS. I will have 20+ users connecting to the server to access the NAS, so i don't want to mount as a specific user, I just want the already established groups and owners to list when a user looks at the directory.  I have also tried using NFS to mount the shares, but instead of the root for group and user, and I get some arbritary number i.e.  4294967294
Here are my autofs config files

Code:
auto.master

/NAS /etc/auto.cifs-shares  --ghost
Code:
auto.cifs-shares

home -fstype=cifs,rw,sec=krb5 ://my-nas/home\$

sssd and kerberos are configured so I am able to login to the unbuntu server with my AD credentials and mount via autofs.

Thanks a lot for you help!
Thomas

1 REPLY 1

tbeaudry

I meant to say that I have also tried using NFS, but it still doesn't work.    Also, if I specify a uid and gid, I get the arbritray number (however, I don't want to have to do this since there will be many users connected to the NAS, as mentioned above).

 

Thanks so much!

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public