Network Storage Protocols Discussions

ISCSI Initiator not starting

marficadmin

Hi All,

Im trying to start the ISCSI initiator service on my RHEL server but its giving the following error:

[root@nfsserver ~]# /etc/init.d/iscsi start
Checking iscsi config: [FAILED]

1. I have downloaded the ISCSI host kit from the now site and installed it on the Linux server.

2. /etc/iscsi.conf and /etc/initiator.iscsi file have been update correctly.

3. everything from teh storage side is setup fine.

Trying to reload gives the following error:

[root@nfsserver ~]# /etc/init.d/iscsi reload
###############################################################################
iSCSI driver is not loaded
###############################################################################

Host details are:

Red Hat Enterprise Linux AS release 4 (Nahant Update 7)

Please let me know if i need to do anything to get the ISCSI initiator services started.

Regards,

Vijay

9 REPLIES 9

Re: ISCSI Initiator not starting

BrendonHiggins

I am not great on Unix but on windows I would confirm that the server NIC can ping the filer. Once this is good I would start with the iSCSI. Are you running iSCSI out of its own NIC on the server?

Re: ISCSI Initiator not starting

marficadmin

We are able to ping the filer from the host and we are not using any dedicted NIC for ISCSI traffic, the ISCSI traffic is routed on the corporate LAN only.

Regards,

Vijay

Re: ISCSI Initiator not starting

marficadmin

running the chkconfig command for teh ISCSI services i get the following output, do anyone have any idea on this?

[root@nfsserver ~]# chkconfig --list iscsi
iscsi 0:off 1:off 2:on 3:on 4:on 5:on 6:off

Regards,

Vijay

Re: ISCSI Initiator not starting

BrendonHiggins

Googled and found this

http://people.redhat.com/mchristi/iscsi/RHEL4/doc/readme

Getting a bit beyond me now. Good luck.

Re: ISCSI Initiator not starting

BrendonHiggins

The SAN Admin Basic course notes say

chkconfig iscsi on

~This enables the iSCSI service

chkconfig -list iscsi

~This command will verify the staus of the iSCSI service.

Hope it helps. Or try logging this issue again on the support side of the forum.

Re: ISCSI Initiator not starting

marficadmin

Hi Brendon,

Thanks for the help, reinstalling the ISCSI RPM on the linux host worked; in fact after reinstalling the RPM a new /etc/iscsi.conf.rpmnew is created and we need to make sure that we edit the correct conf file to add the ISCSI targets.

Regards,

Vijay

Re: ISCSI Initiator not starting

BrendonHiggins

So is it all working now?

Re: ISCSI Initiator not starting

marficadmin

Yup, its working good now.

Regards,

Vijay

Re: ISCSI Initiator not starting

BrendonHiggins

That great. Glade I could help. There should be a "Mark question as answered" button. To close this thread as complete.

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public