Network Storage Protocols Discussions

Issue with roaming profile on Mountain Lion


One of my customer is trying to integrate his Mac clients within Windows 2008 R2 AD.

He has created users with the home directory located on a shared folder (roaming profile).

The situation is:

- if the share is hosted on a Windows server, it works fine and all environment is saved correctly, preferences are saved and retrieved at every session opening and closing.

- if the share is hosted on a NetApp system, on a CIFS share, the preferences are not saved. We can see many files created, but it seems that the system cannot save them correctly.

After further testing, we have tested different versions:

Works perfectly with 10.6.8 (snow leopard), 10.7.5 (Lion) but not with 10.8.3 and 10.8.4 (Mountain Lion)

Temporary files cannot saved on the CIFS shares hosted by the NetApp

Anyone has encountered the issue?

Thanks in advance,



Re: Issue with roaming profile on Mountain Lion

Hey JC!

I am having the same problem! Our environment is exactly the same as yours. We are running on ONTAP 8.1.2 7-Mode with an NTFS only style qtree. And like you we have noticed that this problem only affects Mountain Lion based Macs. The strange thing is that the users can open and edit files on the same home directory, but only the Preference change are ignored.

I can't believe that no one else has noticed this....

Ryan D.

Re: Issue with roaming profile on Mountain Lion

Hello Ryan,

I'm glad to hear that we are not the only one to have the issue.

I've discussed with many people and they don't know any customer using home directories on a network folder.

I have opened a case at Netapp, and I've provided them with packet trace of the SMB session.

I should have a feedback from them next week, I'll keep this thread updated.



Re: Issue with roaming profile on Mountain Lion


I have also the same problem same setup AD Domain, NetApp DataONTAP 8.1.3 7-Mode and 10.8.4 Clients...

I hope NetApp gives soon an answer and a solution.



Re: Issue with roaming profile on Mountain Lion


Here's the latest update from the support regarding the case.

They've found an existing case:

We have also opened a support case by Apple. We have received the following response :

Thank you providing the fsusage data.  The reference number NetApp provided is being used to track future SMB support features in OS X.

This is currently planned for a future software release.

The issue you are encountering is directly related to SMB but is more specific to the current OS X prefs implementation and it interaction with NetApp.

"The NetApp box doesn't support SMB_CAP_INFOLEVEL_PASSTHRU option for SMB1, so you can't delete an open file with this server"

I will follow up with Product Engineering with the data you provided an let you know as soon as I have new information to share.

I hope this is the information you were looking for.

The Apple bug ID that we raised is 11838169 but this burt has been duped to another apple bug 9950485

I'm currently on the phone with an Apple rep trying to see if this bug ID applies to us, and if Apple plans to solve it.



Re: Issue with roaming profile on Mountain Lion


According to Apple, they will implement SMB 2 in new Mac OS X Maverick.

So, this issue should be fixed in the new release.

I'll verify this with my customer as soon as the release is live.



Re: Issue with roaming profile on Mountain Lion


My customer has confirmed that Maverick has solved the issue.

The preferences are working fine now.

I'll keep the thread updated, but for now, for anyone having the issue, consider upgrading to 10.9 Maverick.



View solution in original post

Re: Issue with roaming profile on Mountain Lion

Netapp filers running 7mode, this has been a moot issue for user running OSX 10.6.8 or 10.8.5. because they were using a true SMB client.

OSX 10.7 this all changed, Apple tried to use SAMBA, a SMBlike util, but only supported SMBv1

OSX 10.9 (Mavericks), Apple has abandoned the SAMBA, and written their own SMB server & client, and rumored to be MS-SMBv2 compatible.

And I can attach to my SMB share on our 7mode filer, and everything is working fine.

Now the curveball for all Mac OSX version, does it work under Netapp Cluster Mode env.?

So far, its not working.  They are saying Mac's are not supported.   

I asked:  You mean yet or not at all?  

Still pending an answer.

Cloud Volumes ONTAP
Review Banner
All Community Forums