Network Storage Protocols Discussions

Oops! Had a problem with that Servlet

DarrenSmith

HI

I have a 3020 that was re initialized, I reinstalled Ontap 7.3.3P5 as it was moved to a different site to be recommisioned.

How ever now I get the following errror

HTTP/1.1 500 Internal server error content-type: text/html

Oops! Had a problem with that Servlet

500 Internal server error

java.lang.NullPointerException

at netapp.fv.shelves.ShelfInfoBean.compare(ShelfInfoBean.java:181)

at java.util.TreeMap.compare(TreeMap.java:1047)

at java.util.TreeMap.put(TreeMap.java:449)

at java.util.TreeSet.add(TreeSet.java:198)

at netapp.fv.shelves.ShelfZapi.getShelvesList(ShelfZapi.java:106)

at netapp.servlets.tree.TreeMenu.constructTree(TreeMenu.java:910)

at netapp.servlets.tree.TreeMenu.(TreeMenu.java:46)

at netapp.servlets.tree.TreeServlet.getBody(TreeServlet.java:150)

at netapp.fv.servlets.FilerViewServlet.service(FilerViewServlet.java:572)

at javax.servlet.http.HttpServlet.service(HttpServlet.java:588)

at netapp.servlet.NetappRunner.execute(NetappRunner.java:471)

at netapp.servlet.NetappRunner.run(NetappRunner.java:303)

at java.lang.Thread.run(Thread.java:484)

I've installed Data ontap twice now and still no go

Any help would be apreciated

Thanks

6 REPLIES 6

arunchak

HI,

Few things you can check are:

Check If the client entry is in /etc/hosts.equiv, if yes remove it and try once.

There was a BURT 363139 which was closed after following suggestions:

> As mentioned in the burt description, user is seeing some java servlet

> problem, such type of errors usually happens when -

>  > disks have been zeroed

>  > root volume is offline or unavailable

>  > image of build is corrupt.

>  > contents of the /etc directory (or essential Java files) lost

>  > missing files (netapp.zip, servlet.zip, and rt131.jar  from /etc/java)

>

> Reinstalltion of the software as solution suggested by you is correct and if

> everything goes fine FilerView should work.

That burt was closed after the above info was posted in the burt.

See if this is useful.

Thanks,

  Arun

DarrenSmith

Thanks

I have checked the hosts.equiv file and it's empty.

The disks were all zeroed as I did a full install using option 4a off the special boot menu on friday and then did the Ontap install after that.

The root volume is online.

DarrenSmith

Hi

Just wanted to confirm the reinstall instructions.

I do a software list, and I see the package there.

Then a software upgrade <packagename>

It goes thru and installs.

Then i do a download and reboot.

It all comes back online. I can access cifs shares but then when i go to filer view on the left hand side i get the above error.

Thanks

DarrenSmith

Hi

I re zeroed all the disks and started again redownloaded ontap and still no go.

Any more ideas ?

NETAPPCYP

hi this might be a damn this to check, but after running 4a, you did add a upload the setup files to the system and go through the setup process from the beginning and then added all the licenses required, before a reboot?

Try upgrading to a newer version of DOT and install a newer version after the re-init. process

DarrenSmith

Hi,

Thanks for the suggestion, yep i've run thru the setup and applied licenses. Still no go.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public