Network Storage Protocols Discussions

Problems reinstalling Ontap 7.3.3


I am having problems reinstalling ontap 7.3.3. on a FAS3020.

1. I created a CIFS share and downloaded the Ontap files (733_netboot.e & 733_setup_e.exe) from

to the /etc/software directory.

2. I have puttied into the console and I am running the following command.

npnetapp105>software update 733_setup.e.exe

npnetapp105> software update 733_setup_e.exe  

software: File 733_setup_e.exe not found.
software: installation of 733_setup_e.exe was not successful

What am I doing wrong?


Re: Problems reinstalling Ontap 7.3.3


I'm using this table as a reference.

If you want to...Then you can enter...

Install the new system files from the /etc/software directory

software update my_73_setup_i.exe -d -r

Download the new system files to the boot device immediately after installing them

software update my_73_setup_i.exe -r

Copy and install the image from your HTTP server

software update

Copy from your HTTP server and overwrite an existing image

software update -f

Perform an upgrade on a single system and reboot immediately

software update my_73_setup_i.exe

(Omit the -d and -r options to reboot automatically as soon as the download process completes.)

You can also omit these options for a standard upgrade of systems in an active/active configuration, but only after entering the cf disable command.

Do not enable automatic reboot if you need to upgrade firmware.

Re: Problems reinstalling Ontap 7.3.3


What is the output of "software list" ?  That will show the contents and the file likely doesn't exist as typed...could be a case sensitive issue or written to another controller...  You can also "priv set advanced ; ls /etc/software".  Also, you don't need the netboot file, just the executable elf code for the 3020.  The update command will download and extract the boot image to the flash card.

Re: Problems reinstalling Ontap 7.3.3


Don't forget about filename case.

733_setup_e.exe and 733_setup_e.EXE can be different names for *NIX-like OS

Re: Problems reinstalling Ontap 7.3.3


You might have to check if software list cli able show up the file which you downloaded.



Re: Problems reinstalling Ontap 7.3.3


When I run the software list command  nothing comes up.

Re: Problems reinstalling Ontap 7.3.3


Then it wasn't written to this controller.  It was written to /etc/software somewhere else.  software list will list all software in that directory, or "priv set advanced ; ls /etc/software".

Re: Problems reinstalling Ontap 7.3.3


I rebooted the filer and then looked at share then moved the file to /software instead of  /etc/software then I ran the software list and wham- the file was there. I ran the software update command and all is good. Thanks for the help.

Re: Problems reinstalling Ontap 7.3.3


Excellent...good to hear it upgraded. But something is not right with your nfs export or cifs share.  The file has to reside in /etc/software on the FAS controller.  If copying to /etc/software didn't work, then /etc/software is a mount point somewhere else.  I suspect that your mount point is already at ETC$.  So when you copied the file it was in /etc/etc/software and then was moved to /etc/software.  Mount C$ or /vol/vol0 (or whatever root is) then you will probably find the nested /etc/etc directory.   Running "priv set advanced ; ls /etc/software" will show that the file is in the correct path.

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums