Network Storage Protocols Discussions

Highlighted

Quota over NFS doesn't work.

Hi.

How can I enable quota over NFS for my linux clients? (CentOS 7)

I have issued "nfs modify -vserver $SVM_NAME -rquota enabled" command, but still can't get 'quotaon' to work in client (using ver 4 of NFS).

 

[root@cameron ~]# quotaon -u /mnt/netapp_home
quotaon: Mountpoint (or device) /mnt/netapp_home not found or has no quota enabled.

 

Do I need anything else in client side? Or ONTAP just doesn't support it?

 

Tks!

 

6 REPLIES 6
Highlighted

Re: Quota over NFS doesn't work.

Hello

 

From the command you issuing it seems that you are enabling rquota ( remote quota). If you are referring to quota, you will need to create  a policy on the volume level and proceed and enable quota.

 

Below is couple link to help you with your request:

 

https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.onc-sm-help-930%2FGUID-216B190A-D047-4514-B267-9ED3D7AA4A18.html

 

https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.dot-cm-vsmg%2FGUID-97EF386D-0746-4196-AEF2-6B5A297D8645.html

Highlighted

Re: Quota over NFS doesn't work.

Actually, I would like to set and read quota information from my linux client, that's why I enabled remote quota. But still doesn't work. 

I'm wondering if Netapp support it or if I need any other parameter during mount (like 'usrquota' for local filesystems).

Thep oint is that I can't set and get quota information from my linux client.

Highlighted

Re: Quota over NFS doesn't work.

Hello

ONTAP supports the remote quota protocol version 1 (rquota v1).
The rquota protocol enables NFS clients to obtain quota information for users from a remote machine.

Are you only using NFS v4 in your environement?
Is NFS v3 enable at the export policy level?

I would recommend adding NFSv3 to export policy alongside with NFSv4.

Highlighted

Re: Quota over NFS doesn't work.

Hi Jonis,

 

We have made improvements to better support rquota with ONTAP 9.6 and more so in ONTAP 9.7. Which ONTAP version are you using? There are other options that must be configured as well for quotas to work. Have you configured a quota policy for the volume specifically using the command "volume quota policy rule create"?

 

You can reference this for more details on the command:

https://library.netapp.com/ecmdocs/ECMP1366832/html/volume/quota/policy/rule/create.html

 

 

Regards,

 

Team NetApp

Team NetApp
Highlighted

Re: Quota over NFS doesn't work.

Hi Guys!

I'm using ONTAP 9.6 and I managed to get it working, everything was fine, just my client isn't seen quota.

The only remaining 'problem' is to set quota using client. Is it possible? I don't think so, but you are the experts and know the answer.

Highlighted

Re: Quota over NFS doesn't work.

 

rquota version 1 is the only verison supproted. 

You should be able to test if the rquota is working by running the below command from the filer and the linux box and make sure it match:

 

Filer side: volume quota report -vserver <name> -volume <vol> 

Host Side: quota -u <username>

 

 

 

Check out the KB!
NetApp Insights To Action
All Community Forums