Network Storage Protocols Discussions

Windows 10 Clients UNABLE to search CIFS

PWn3R

Hi All -

 

I've read a large number of the threads out here in detail. We are running 9.4P3 on our system and are hosting several MASSIVE shares with multiple millions of files and folders. 

 

We moved the data off a NetApp to a Windows box back in 2014 and then back to a new NetApp in 2018. I do not see any attributes on the files saying they are indexed or other obvious issues.

 

What we are seeing is that files are not searchable. I'm not talking about not indexed (I don't believe that is supported still) as in they don't show up EVER in the search results, and the results instantly return what *appear* to be indexed results from before this content was moved to the NetApp in '18. 

 

Has anyone else run into this? Does anyone have a way to fix this? I've tried disabling Windows Search service on test machines and several other things, but nothing I've tried seems to be fixing this issue. We have to be able to search these shares, and we have users complaining for good reason.

 

I did see the third party plugin that is for sale that allows indexing on the NetApp but we aren't going to spend $250K+ on a plugin to index the contents.

5 REPLIES 5

Re: Windows 10 Clients UNABLE to search CIFS

hmoubara

Hello,

 

NetApp is yet to support indexing. Have you looked into XCP software offered from NetApp.

https://docs.netapp.com/ontap-9/topic/com.netapp.doc.cdot-famg-cifs/GUID-D9E07C52-CF93-47B4-8113-C4CFB066D975.html

 

https://library.netapp.com/ecm/ecm_download_file/ECMLP2865035

Scan - discovery and statistics of files and directories

Starting from any directory, XCP recursively reads all the subdirectories and can produce listings and reports in human-readable and machine-readable formats. Thanks to the matching and formatting capabilities, the reports can be highly customized to match any reporting needs. Any file attribute such as the access time, owner, group, size, etc. are eligible criteria's for filtering out the files in a report. Output formats include CSV, HTML or plain text listing.

 

Thanks

Re: Windows 10 Clients UNABLE to search CIFS

parisi

I am able to search NetApp CIFS shares on my Windows 2016 server.

 

For example, in this share, I have a few files called "linked-file-shortcut."

 

Here's one of them:

 

parisi_3-1617115145016.png

 

 

Here's what find/search gives:

 

parisi_2-1617115131272.png

 

Does this work on other Windows boxes? Perhaps you need to clear the index cache on the client?

 

https://www.thewindowsclub.com/windows-edb-file#:~:text=To%20delete%20and%20rebuild%20the,safe%20to%20delete%20the%20Windows.

 

Re: Windows 10 Clients UNABLE to search CIFS

PWn3R

Hi -

 

I've been able to replicate this problem from domain controllers with no software installed running 2019. I have also seen it work correctly from a different 2019 server. This issue has been confirmed on MULTIPLE different Windows 10 clients, including some with no history of accessing this share. We tried deleting the search index cache, as well as searching with Windows Search service stopped and disabled.

 

The behavior we are getting is such that it appears to be not even attempting to actually enumerate directories and files in the search, just instant return of only 1 stale result.

Re: Windows 10 Clients UNABLE to search CIFS

PWn3R

Hi @hmoubara 

 

I was not familiar with this, but this is not something that I can deploy to all the users that need to search these fileshares that are seeing searching problems are used by thousands of employees. A static report or asking them to run one each time isn't going to work well. I need to fix the Windows 10 search results.

Re: Windows 10 Clients UNABLE to search CIFS

PWn3R

Another note if someone finds this looking for help. This problem appears to be related to the version of Windows 10 that was deployed to our clients. We have a lot of application vendors who don't even endorse Windows 10 yet, or want _REALLY_ old versions. We deployed 1809 against recommendations from many of them, and apparently this issue is a problem with network file share searching in 1803 and 1809. It was supposedly fixed in 1903 and later. We are seeing signs this is correct, but need to further validate.

View solution in original post

Earn Rewards for Your Review!
GPI Review Banner
All Community Forums
Public