Network Storage Protocols Discussions

XCP 1.4 permission problem

I’ve been struggling with this problem and couldn't figure it out why.

I ‘m working on data migration from a NetApp (old NetApp) running on 7-mode to another NetApp (new NetApp) running on ONTAP 9.6

On old NetApp, the /etc/exports:

“..

/vol/vol_b_nfs01        -sec=sys,rw=192.168.23.182,root=@repoadm,nosuid

..

“ where 192.168.23.182 is the IP of my Linux XCP server. The IP is also in @repoadmin group too.

 I did “xcp scan <old NetApp IP>:/vol/vol_b_nfs01” .

In the output, I have several error with “permission denied”.

For instance:

“xcp 2019-10-23 20:11:41 rd '<old NetApp IP>:/vol/vol_b_nfs07/users/1031702/.gconfd' fileid 6062828 ERROR: nfs3 READDIRPLUS '<old NetApp IP>:/vol/vol_b_nfs07/users/1031702/.gconfd' cookie 0 maxcount 65536: nfs3 error 13: permission denied”

 

When I mounted the volume and did the listing, I noticed, those gave me “permission denied” don't have  read permission for others , and I did have permission denied when I tried to read them,  although the owner& group is root and I logged in as root and the permission to read is set for both owner + group.

It means somehow, the NetApp didn’t recognize root user on XCP server (I ran xcp scan as root)

Anyone seen this before?
Thanks.

1 REPLY 1

Re: XCP 1.4 permission problem

Figured it out. I explicitly put the IP of XCP server in "root=" rather than the netgroup @repoadm.

 

Forums