Network Storage Protocols Discussions

cifs share with default permissions everyone/Full control asks for username/password

maskajan09

Hello

I already don't know how to fix it. If create a share that has default permissins everyone/Full control I would expect that I can connect it w/o problems right after the creation from everywhere and with whatever account. But it asks for credentials. I don't understand this. Can anybody explain to my what is wrong??

Thank you

 

BTW I set the export policy for this share to be accessible from everywhere.

1 ACCEPTED SOLUTION

maskajan09

You need to apply the export policy also to the root volume of the SVM (the root where you mount your data volumes). Then it works. Smiley Frustrated

View solution in original post

5 REPLIES 5

cedric_renauld

Hello, 

 

In your case, it's depend about your share

Can you see us the share ?

by :

vserver cifs share show

 And answer some questions:

- Wath's your cDOT version ?

- Are you in AD environnement ?

 

Cedric 

maskajan09
aff::> cifs share show
Vserver        Share         Path              Properties Comment  ACL
-------------- ------------- ----------------- ---------- -------- -----------
svm1           admin$        /                 browsable  -        -
svm1           c$            /                 oplocks    -        BUILTIN\Administrators / Full Control
                                               browsable
                                               changenotify
                                               show-previous-versions
svm1           cifsdata      /svm1_data        oplocks    -        Everyone / Full Control
                                               browsable
                                               changenotify
                                               show-previous-versions
svm1           ipc$          /                 browsable  -        -

ontap 9.3P11

no domain, just workgroup

Thank you

cedric_renauld

Oki, in your case, the right question is :

- The guest user is activated ?

To activate the guest user cifs follow this procédure to activate it and bypass the user login :

See the doc :  https://docs.netapp.com/ontap-9/index.jsp?topic=%2Fcom.netapp.doc.cdot-famg-cifs%2FGUID-76186CB7-BFD0-4EA1-9CA5-07DC8D6A2BAF.html

 

  1. Set the privilege level to advanced:set -privilege advanced
  2. Configure the restrict anonymous setting:vserver cifs options modify -vserver vserver_name -restrict-anonymous {no-restriction|no-enumeration|no-access}
  3. Verify that the option is set to the desired value:vserver cifs options show -vserver vserver_name
  4. Return to the admin privilege level:set -privilege admiEnjoy 

maskajan09

there is 

no-restriction

so it sould work 😞

maskajan09

You need to apply the export policy also to the root volume of the SVM (the root where you mount your data volumes). Then it works. Smiley Frustrated

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public