Network Storage Protocols Discussions

netapp nfs mount permission denied

I came across a nfs mount problem today;

/vol/fnd_git is a newly created volume....

filer01>exportfs -i -o  rw=10.74.XX.20,root=10.74.XX.20,nosuid /vol/fnd_git

filer01> exportfs

/vol/fnd_git    -sec=sys,rw=10.74.XX.20,root=10.74.XX.20,nosuid

[root@linux_client~]# cat /etc/redhat-release

CentOS release 5.5 (Final)

[root@linux_client~]# mount filer01:/vol/fnd_git  /test   ===>no problem here, can mount successfully

[root@linux_client~]# cd /test                                  ==========>but denied here

-bash: cd: /test: Permission denied

I even tried another 2 clients(one is solaris10 zone, the other is debian linux VM), and it is the same result :  can mount successfully,but permission denied if try to "cd" or "ls"

it's confusing

could it be psosible relate to networking issue – either firewall or nat’ing? I am not sure, if yes, how can I trouble shoot?

I am a newbie of Netapp....please help


netapp nfs mount permission denied

What security style does the volume have? If it is ntfs, then ntfs permission could prevent user access.

You can check the security style with the "qtree status fnd_git" command.

View solution in original post

netapp nfs mount permission denied

yes, it is indeed ntfs ,how could I change?

filer01> qtree status fnd_git

Volume   Tree     Style Oplocks  Status  

-------- -------- ----- -------- ---------

fnd_git           ntfs  enabled  normal

filer01> options wafl.default_security_style

wafl.default_security_style  ntfs 

netapp nfs mount permission denied

I read from the forum that currently there are no APIs available to set/change the security style of qtrees. and the  qtree-create API sets the security style of the qtree to the default value specified in the option wafl.default_security_style.

So should I set the fl.default_security_style to unix first then recreate the volume?

netapp nfs mount permission denied

hi, Pascal

thanks very much!

I destoryed the volume fnd_git and set wafl.default_security_style to unix

then I recreate the volume fnd_git, then this new volume inherits the security style to unix.......

now it work!  the linux server have access and write permission now!

netapp nfs mount permission denied

There was not need to destroy the volume as you can change the security style online using the CLI by treating the volume like a qtree.

> qtree security /vol/fnd_gi unix

netapp nfs mount permission denied

okay, i thought I can not change the security attribute of qtree through CLI....I made a mistake....

since the volume is new and no data so I destoryed it yesterday...

thanks very much

Cloud Volumes ONTAP
Review Banner
All Community Forums