ONTAP Discussions
ONTAP Discussions
I have a FAS 2050 setup with 4 nics in a multimode LACP config. We are using vlan tagging load balance ISCSI, NFS traffic. We had the system setup and working properly using Cisco switches. We recently upgraded to Juniper ex4200 switches. We have been unable to connect to the filers with the new switches.
Each netapp filer has 4 1gb NICs. They are setup in a single multimode vif using vlan tagging to isolate ISCSI and NFS traffic.
The juniper switches are using the below config to trunk the ports the filers plug into. Anyone have any ideas of what we maybe missing?
version 10.0S6.1;
…
interfaces {
ge-0/0/0 {
ether-options {
802.3ad ae0;
}
}
ge-0/0/1 {
ether-options {
802.3ad ae0;
}
}
…
ge-1/0/0 {
ether-options {
802.3ad ae0;
}
}
ge-1/0/1 {
ether-options {
802.3ad ae0;
}
}
…
ae0 {
description "LACP VIF for NetApp";
aggregated-ether-options {
lacp {
active;
}
}
unit 0 {
family ethernet-switching {
port-mode trunk;
vlan {
members [ iscsi nfs snapmirrir_and_nfs ];
}
native-vlan-id default;
}
}
}
vlan {
unit 0 {
family inet {
address 10.10.11.1/24;
}
}
unit 1 {
family inet {
address 10.10.20.1/24;
}
}
unit 2 {
family inet {
address 10.10.30.1/24;
}
}
unit 3 {
family inet {
address 10.10.40.1/24;
}
}
}
}
}
vlans {
default {
vlan-id 4094;
l3-interface vlan.0;
}
iscsi {
vlan-id 20;
l3-interface vlan.1;
}
nfs {
vlan-id 30;
l3-interface vlan.2;
}
snapmirrir_and_nfs {
vlan-id 40;
l3-interface vlan.3;
}
}
change your VIF configuration to lacp (vice multimode). i think the juniper part is setup right. I have a similar configuration that works, except its dual 10G in an LACP vif. But I'm not vlan trunking.
How do you configure the vif side to recognize the vlans? do you just use alias IPs on the appropriate networks?
The filer vif was created as lacp (as near as I can remember). See below for the vif status output. I am assuming that VIF Type 'lacp' verifies that the VIF is indeed set to lacp.
Yes we are using alias IP addresses for each vlan network. As I said, we had the lacp configuration up and running on previous cisco switches.
Can you reconfigure the switches to merge the iscsi/nfs/snapmirror_and_nfs vlans just for the moment? To see if that fixes the connectivity issue? Next I'd probably open a ticket with Juniper (or complain to your Juniper sales engineer) that Juniper equipment can't do something Cisco can. My only remaining concern is how are you setting which alias IP goes to which vlan? Might want to get into the weeds with NetApp regarding how vif's handle vlan trunking. Maybe their method isn't compatible with Junipers?
Wish I could be of more help.
-Ed
Anyone know how to verify what the default VLAN id is set to on the filer?