ONTAP Hardware

VSC for VMware vSphere - Failed to Register with vCenter

nr3
1,091 Views

While trying to register VSC 6.2.1 after Setup with vCenter 7.x it fails with the following Error message:
Registration failed with the following message: NVPF-00001: Invalid vSphere credentials: Reason: java.rmi.RemoteException: VI SDK invoke exception:org.dom4j.DocumentException: Error on line 1 of document : Content is not allowed in Prolog. Nested exception: Content is not allowed in Prolog.

I know that there is a workaround but I was unable to apply it. Does anyone have the patched .jar files or an idea where to get them ?
https://communities.vmware.com/t5/vSphere-Client-SDK-Discussions/VCSA-6-9-2-VI-Java-SDK-connection-failure-exception/td-p/2220683

6 REPLIES 6

Ontapforrum
1,056 Views

It could simply be unsupported configuration.

 

Are you sure it is VSC 6.2.1 ? NetApp IMT (Interoperability Matrix) does not show the compatibility of VSC 6.2.1 with vCenter 7.x, the max supported version of vCenter is 6.5U1 (For VSC6.2.1).

 

Anyway, there is one old thread here suggesting to avoid any escape characters in the username/password.
https://community.netapp.com/t5/VMware-Solutions-Discussions/Cannot-register-plugin-VSC-2-0/m-p/35254

nr3
1,032 Views

Thanks for your reply. Yes it's for sure this Version and the solution in the thread you gave me also didn't work for me. I know that there is no official support, but it should also be possible to patch it and then it should work. I just don't know how to patch 😥

nr3
996 Views

The registration now works, but I don't see it in the vCenter. After investigating I figured out that I have the wrong extensions (I think) and I am not able to download the correct ones as described here: https://kb.netapp.com/Advice_and_Troubleshooting/Data_Storage_Software/VSC_and_VASA_Provider/Virtual_Storage_Console:_User_Interface_extensions_are_no...
--> wget --no-check-certificate https://<vsc_server>:8143/htmlclient_deployment_bundle
In my case I always have a "HTTP request sent, awaiting response... 403 Forbidden"
I think I need the extension "com.netapp.vsch5-9.x", but I only have the extension "com.netapp.nvpf.webclient-6.x"
Even a reinstallation did not solve the problem.

paul_stejskal
990 Views

It may just not work due to the age of the product. Can you upgrade to a newer version of ONTAP Tools (newer version of VSC)?

 

nr3
973 Views

I don't think so, it's for a FAS2240-2 with NetApp Release 8.2.5P5 7-Mode 😥

paul_stejskal
859 Views

Dang. I'm sorry. 😞

 

Public