ONTAP Rest API Discussions

Netapp Powershell script

MohanCBE
1,215 Views

we are trying to create a script to create the user share folder and setting up required permission as per customer defined standards but we are getting the below error  PFA of the error .

we have enabled the HTTP but still we are facing the issue .Please find the output of system webservices show.

External Web Services: true
Status: online
HTTP Protocol Port: 80
HTTPS Protocol Port: 443
HTTP Enabled: true

 

1 ACCEPTED SOLUTION

RobertBlackhart
1,180 Views

Your script is trying to use port 2530, but the output above you're showing is that HTTP is enabled on port 80. Is there a reason that you're specifying port 2530 in your script? If you do need it to be port 2530, you'll need to modify the web server on your cluster to listen on that port (which must be done at diag privilege):

 

cluster::*> set diag

Warning: These diagnostic commands are for use by NetApp personnel only.
Do you want to continue? {y|n}: y

cluster::*> system services web modify ?
  [[-external] {true|false}]                  External Web Services
  [ -http-port <integer> ]                    *HTTP Port
  [ -https-port <integer> ]                   *HTTPS Port
  [ -per-address-limit {24..999} ]            *Per Address Limit
  [ -wait-queue-capacity <integer> ]          *Wait Queue Capacity
  [ -http-enabled {true|false} ]              *HTTP Enabled
  [ -csrf-protection-enabled {true|false} ]   *CSRF Protection Enabled
  [ -csrf-token-concurrent-limit {0..9999} ]  *Maximum Number of Concurrent CSRF Tokens
  [ -csrf-token-idle-timeout <integer> ]      *CSRF Token Idle Timeout (Seconds)
  [ -csrf-token-absolute-timeout <integer> ]  *CSRF Token Absolute Timeout (Seconds)

cluster::*> system services web modify -http-port 2530

Warning: Modification of the web server port requires the firewall policy to be updated. Do you want to add the port to the existing "http" firewall policy service? {y|n}: y

The firewall port for "http" has been updated to "2530".

cluster::*>

 

 

View solution in original post

2 REPLIES 2

RobertBlackhart
1,181 Views

Your script is trying to use port 2530, but the output above you're showing is that HTTP is enabled on port 80. Is there a reason that you're specifying port 2530 in your script? If you do need it to be port 2530, you'll need to modify the web server on your cluster to listen on that port (which must be done at diag privilege):

 

cluster::*> set diag

Warning: These diagnostic commands are for use by NetApp personnel only.
Do you want to continue? {y|n}: y

cluster::*> system services web modify ?
  [[-external] {true|false}]                  External Web Services
  [ -http-port <integer> ]                    *HTTP Port
  [ -https-port <integer> ]                   *HTTPS Port
  [ -per-address-limit {24..999} ]            *Per Address Limit
  [ -wait-queue-capacity <integer> ]          *Wait Queue Capacity
  [ -http-enabled {true|false} ]              *HTTP Enabled
  [ -csrf-protection-enabled {true|false} ]   *CSRF Protection Enabled
  [ -csrf-token-concurrent-limit {0..9999} ]  *Maximum Number of Concurrent CSRF Tokens
  [ -csrf-token-idle-timeout <integer> ]      *CSRF Token Idle Timeout (Seconds)
  [ -csrf-token-absolute-timeout <integer> ]  *CSRF Token Absolute Timeout (Seconds)

cluster::*> system services web modify -http-port 2530

Warning: Modification of the web server port requires the firewall policy to be updated. Do you want to add the port to the existing "http" firewall policy service? {y|n}: y

The firewall port for "http" has been updated to "2530".

cluster::*>

 

 

hmoubara
1,011 Views

hello MohanCBE,

 

Does the above step and recommendation solve your issue with the script?

 

Thanks 

Public