OnCommand Storage Management Software Discussions

API services 2.1 install problems

Hello,

 

FIrst time installing API Services. But running to following installation issue.

 

Dependencies Resolved

=========================================================================================================================
Package Arch Version Repository Size
=========================================================================================================================
Installing:
api-server x86_64 2.1.0-1801112243 /api-server-2.1.0-1801112243.x86_64 179 M
netapp-application-server x86_64 7.3.0-2017.10.J293 /netapp-application-server-7.3.0-2017.10.J293.x86_64 134 M
netapp-platform-base x86_64 7.3.0-2017.10.J293 /netapp-platform-base-7.3.0-2017.10.J293.el7.x86_64 3.3 M
ocie-au x86_64 7.3.0-2017.10.J11 /ocie-au-7.3.0-2017.10.J11.x86_64 28 M
ocie-server x86_64 7.3.0-2017.10.J11 /ocie-server-7.3.0-2017.10.J11.x86_64 13 M

Transaction Summary
=========================================================================================================================
Install 5 Packages

Total size: 357 M
Installed size: 357 M
Downloading packages:
Running transaction check
Running transaction test
Transaction test succeeded
Running transaction
Installing : netapp-application-server-7.3.0-2017.10.J293.x86_64 1/5
Installing : netapp-platform-base-7.3.0-2017.10.J293.x86_64 2/5

ERROR: Unable to prepare UDS. MySQL command failed.

warning: %post(netapp-platform-base-7.3.0-2017.10.J293.x86_64) scriptlet failed, exit status 1
Non-fatal POSTIN scriptlet failure in rpm package netapp-platform-base-7.3.0-2017.10.J293.x86_64

FAILURE: netapp-platform-base package is installed, but in corrupt state. Install netapp-platform-base package and try again.

error: %pre(ocie-server-0:7.3.0-2017.10.J11.x86_64) scriptlet failed, exit status 255
Error in PREIN scriptlet in rpm package ocie-server-7.3.0-2017.10.J11.x86_64
error: ocie-server-0:7.3.0-2017.10.J11.x86_64: install failed

ocie-server package is not installed. Install ocie-server package and try again.

error: %pre(ocie-au-0:7.3.0-2017.10.J11.x86_64) scriptlet failed, exit status 255
Error in PREIN scriptlet in rpm package ocie-au-7.3.0-2017.10.J11.x86_64
error: ocie-au-0:7.3.0-2017.10.J11.x86_64: install failed
Installing OnCommand API Services
Installing : api-server-2.1.0-1801112243.x86_64 5/5
Error unpacking rpm package api-server-2.1.0-1801112243.x86_64
error: unpacking of archive failed on file /opt/netapp/essentials/au/conf/preferences/disable-zapis-list.properties;5af0b9b3: cpio: open
Verifying : netapp-application-server-7.3.0-2017.10.J293.x86_64 1/5
Verifying : netapp-platform-base-7.3.0-2017.10.J293.x86_64 2/5
Verifying : api-server-2.1.0-1801112243.x86_64 3/5
Verifying : ocie-server-7.3.0-2017.10.J11.x86_64 4/5
Verifying : ocie-au-7.3.0-2017.10.J11.x86_64 5/5

Installed:
netapp-application-server.x86_64 0:7.3.0-2017.10.J293 netapp-platform-base.x86_64 0:7.3.0-2017.10.J293

Failed:
api-server.x86_64 0:2.1.0-1801112243 ocie-au.x86_64 0:7.3.0-2017.10.J11 ocie-server.x86_64 0:7.3.0-2017.10.J11

Complete!
Error installing OnCommand API Services.

 

 

Running "CentOS Linux release 7.4.1708".

 

Tried installing the failed packages individually, but no luck. 

 

Read the following thread.  They got the exact same error. Thought I would give it a try.

 

https://community.netapp.com/t5/OnCommand-Storage-Management-Software-Discussions/API-Service-1-2-install-problem/td-p/130124/page/2

 

Installed 5.6.35. Now I Oncommand APi wn't recognize the MYSQL dsitribution

 

[Error] :: No MySQL server editions found installed or configured in the existing yum repositories.
[Error] :: Please refer to the Installation and Administration Guide to correct this issue.

 

 

This is what I have currently on my system

 

rpm -qa | grep -i mysql
MySQL-embedded-5.6.35-1.el7.x86_64
MySQL-devel-5.6.35-1.el7.x86_64
MySQL-test-5.6.35-1.el7.x86_64
MySQL-shared-5.6.35-1.el7.x86_64
MySQL-server-5.6.35-1.el7.x86_64
MySQL-client-5.6.35-1.el7.x86_64
MySQL-shared-compat-5.6.35-1.el7.x86_64

 

 

 

Your help is greatly appreciated

 

Thanks

 

Shyam

1 REPLY

Re: API services 2.1 install problems

Never mind. I figured it out myself.  After posting it on this forum, I went back and did a clean install which completed successfully. This particuler system was isolated, it does not have access to yum repositories. By manually installing, I messed it up. Had to completely remove and did a clean install which did the trick.

 

API Version : 2.1

OS : Centos 7.4 (DIsable SElinux)

MYSQL : 5.7.22

Forums