CLI not allowing commands to run...

Hi guys,

Was hoping for a little advise… I’m funning DFM 4.0.2 and have setup my AD user acct in with GlobalFullControl…. Using the NMC or the WebUI, I have no issues doing ll administrative tasks. However; when using the CLI (RHEL 5.6) I can’t run the most basic commands, it’s telling me that the user doesn’t have the proper permissions….

Logged in as root on my  dfm server, I can clearly see that my AD account has been setup with GlobalFullControl.

[root@dfmserver ~]# dfm user role list <a-username>

Role Id Role Name

------- -------------------------

30      GlobalFullControl

However; as mentioned above, when running basic commands from the cli, I get the following

[a-username@dfmserver ~]$ dfm user role list <a-username>

Error: To use the list command, you must have Global DFM Database Read capability.

[a-username@dfmserver ~]$ dfm run cmd <filer_name> version

Error: DFM Console Execute permission denied on <filer_name>.

If anyone could shed a little light on this, I would be most grateful.



CLI not allowing commands to run...

If your DFM server is running 2008 I would turn off the User Account Control setting, this can cause issues with admin rights.

CLI not allowing commands to run...

I'm running RHEL 5.6.

Re: CLI not allowing commands to run...


Thanks for the tip--it worked for me and I had a Win2k8R2 instance.


Re: CLI not allowing commands to run...

What are the DFM permissions?  I see with root you get a response, but in your follow ups you have a-username....have you tried giving a-username sudo access and running it under elevated privileges?  It might be you are getting a Unix perm error after the base DFM commands are being run, this doesn't seem likely as you are getting a DFM denied message, but still worth a try.

- Scott