Re: Dynamic Secondary Volume Resize not Working


We use DFM Version: (5.1) and what we are seeing is that volumes are not automatically enlarged by Protection manager in the dataset....

This is the setup:

Primary -> backup -> mirror

Volumes (snapmirrored & snapvault) between primary and backup are automatically enlarged via DSS (you see the msg in the joblog) but when mirroring from backup

to the mirror, it only says that the volume is to small (s1filerc.sitanl.suez: destination volume too small; it must be equal to or larger than the source volume) without taking action.

If you however enlarge it manually by doing a vol size <volume> +xg , the volume just enlarges and the error goes away

Re: Dynamic Secondary Volume Resize not Working

we run 5.1 and had these problems as well. dss tried to resize volumes to a size the machine cant handle. we disabled it and manually resize.

One workaround was to create a big dummy volume and fill up the Aggregate to a size dss could handle.

Re: Dynamic Secondary Volume Resize not Working

Hi Thomas

Well, that's indeed a workaround. Nevertheless, our integrator is looking into it with NetApp and probably we are suffering from a known bug:   (Documented Issue 677951 which is funny because it doesn't have any info) but it's not certain so we are now running diagnostics with DFM and Netapp will investigate. I'll keep this thread updated with the findings.


Re: Dynamic Secondary Volume Resize not Working


most bug infos arent public available, there are internal notes tho, hopefuly they work on a fix, but i wont expect it to be included in 5.2 unfortunately.

Re: Dynamic Secondary Volume Resize not Working

Hi Thomas,

     Can you pls give the output of the following cli in your case which is not working ?

dfpm dataset list -R <dataaset-name-or-id>



Re: Dynamic Secondary Volume Resize not Working

PS C:\Users\snapdrive> dfpm dataset list

Id         Name                        Protection Policy           Provisioning Policy Application Policy          Storage Service

---------- --------------------------- --------------------------- ------------------- --------------------------- ---------------





      3231 SnapMgr_Exchange_EXSERVER   CUSTOMER_Exchange_SnapVault_only

      3371 SnapMgr_SQLServer_SQLSERVER  CUSTOMER_Sharepoint_Snapvault_only

PS C:\Users\snapdrive> dfpm dataset list -R 1138

Id         Name                        Protection Policy           Provisioning Policy Relationship Id State        Status  Hours Source                       Destin


---------- --------------------------- --------------------------- ------------------- --------------- ------------ ------- ----- ---------------------------- ------


      1138 CUSTOMER_FILESERVICE_SHARES     CUSTOMER_FILESERVICE_POLICY                                    6549 snapvaulted  idle    11.0  VFSERVER:/vol_VFSERVER_shares/qt_sh

are01 NETAPP03:/vol_VFSERVER_shares_2/qt_share01

      1138 CUSTOMER_FILESERVICE_SHARES     CUSTOMER_FILESERVICE_POLICY                                    6550 snapvaulted  idle    11.0  VFSERVER:/vol_VFSERVER_shares/qt_sh

are03 NETAPP03:/vol_VFSERVER_shares_2/qt_share03

      1138 CUSTOMER_FILESERVICE_SHARES     CUSTOMER_FILESERVICE_POLICY                                    6551 snapvaulted  idle    11.0  VFSERVER:/vol_VFSERVER_shares/qt_sh

are02 NETAPP03:/vol_VFSERVER_shares_2/qt_share02

      1138 CUSTOMER_FILESERVICE_SHARES     CUSTOMER_FILESERVICE_POLICY                                    6552 snapvaulted  idle    11.0  VFSERVER:/vol_VFSERVER_shares/qt_sh

are04 NETAPP03:/vol_VFSERVER_shares_2/qt_share04

      1138 CUSTOMER_FILESERVICE_SHARES     CUSTOMER_FILESERVICE_POLICY                                    6611 snapmirrored idle    6.1   NETAPP03:/vol_VFSERVER_shares_2 GDF


PS C:\Users\snapdrive>

Re: Dynamic Secondary Volume Resize not Working


The same Problem here (Do you have you received a Solution from Netapp in the Meantime?) :



- My Dataset

U:\>dfpm dataset list -R 96671

Id         Name                        Protection Policy           Provisioning Policy Relationship Id State        Status  Hours Source                       Destination

---------- --------------------------- --------------------------- ------------------- --------------- ------------ ------- ----- ---------------------------- ----------------------------

96671 Dataset1      Standard                                           96678 snapvaulted  idle 9.9 vfilerprod:/vfilerprod_cifs_share2/- vfilerSV:/Standard_backup/cifs_share2

96671 Dataset1      Standard                                           96680 snapvaulted  idle    9.9 vfilerprod:/vfilerprod_cifs_share1/- vfilerSV:/Standard_backup/cifs_share1

96671 Dataset1      Standard                                           96682 snapvaulted  idle    9.9 vfilerprod:/vfilerprod_cifs_share2/dbbackuppf vfilerSV:/Standard_backup/dbbackuppf

96671 Dataset1      Standard                                           96684 snapvaulted  idle 9.9 vfilerprod:/vfilerprod_cifs_share1/dbbackupab1 vfilerSV:/Standard_backup/dbbackupab1

96671 Dataset1      Standard                                           96688 snapmirrored idle    46.7  vfilerSV:/Standard_backup filerSM:/Standard_mirror

- Snapvault Volume Size reported by DFM Report

U:\>dfm report view volumes-capacity 96674

Object ID Volume           Aggregate Storage Server                               Used        Total       Used (%)

--------- ----------------------------- --------- ------------------------------- ----------- ----------- --------

96674     Standard_backup aggr3     vfilerSV.domain                               10256589560 16066582712     63.8

Totals                                                                            10256589560 16066582712     63.8

- Snapvault Volume Size on Controller

filerSV> df -V Standard_backup

Filesystem kbytes       used      avail capacity  Mounted on

/vol/Standard_backup/ 16066582712 10256890328 5809692384      64% /vol/Standard_backup/

/vol/Standard_backup/.snapshot 0 8882897080          0     ---% /vol/Standard_backup/.snapshot

- The Remote Backup DSS Job report a current Total Size of 2TB (instead of 14TB). In the Past Every Job report this 2 TB and resize to 14TB, but on the controller its already 14TB . Fact is DSS read the wrong Value of 2TB every Time DSS runs.

- Snapmirror Volume Size on Controller

filerSM> df -V Standard_mirror

Filesystem kbytes       used      avail capacity  Mounted on

/vol/Standard_mirror/ 15350455768 9670474332 5679981436 63%  /vol/Standard_mirror/

/vol/Standard_mirror/.snapshot          0 8288095364          0 ---%  /vol/Standard_mirror/.snapshot

- The Mirror Backup DSS Job try to resize to 2TB (I Think its because the wrong 2TB is reported as current Size from Backup DSS Job and the resize fails.Then the snapmirror Job fails because the current Size of the snapmirror Volume is a few Bytes   smaller (16066582712-15350455768=716126944B~683MB).

- We have 76 Datasets (Oracle_Snapcreator/SMSQL (Backup only)/CIFS/NFS)and this happen only on 1 Datasets since few Weeks and on 2 other Dataset sporadically.



Re: Dynamic Secondary Volume Resize not Working


What did you do before this to get this error. What were you resizing, the primary, secondary, etc.

I am trying to get reproducible steps to take to get this problem. I am a dev for OnCommand trying to fix this issue.


Re: Dynamic Secondary Volume Resize not Working


I'm not Thomas but, I had the same kind of issue on one volume last week (DR Mirror then Backup policy).

One secondary volume had an issue resizing (all other volumes in the dataset worked well), and then the Mirror Job finished with "Some storage members for dataset still not found after running fsmon".

After that, all backup jobs for the dataset failed even for volumes were snapmirror went well (First question: is this normal ?)

What made me answer to your question there is I noticed something on the screen shots above.

The value for new total is the exact same number that I saw on other screenshots in the thread. I don't know if it means something but it seems to me an enormous coincidence, or may be it is a special value ...

In our case, the backups have been running well for weeks/months. On the day before, some qtree were provisionned in the dataset (in the volume that failed) using provisioning manager as it was done tens of times before.

But the night after, Protection Manager failed to resize (I would notice as well, that DFM said it would sized down the mirror, but if failed because it needed a size up since the customer added new qtrees and the primary volumes was growing).

The screenshot:


Re: Dynamic Secondary Volume Resize not Working

Hi Stephanie

Befor this Error happen I have did following Steps:

- Because an other Issue, I have removed the Mirror Nodes from the dataset.

- Provisioning Manager has made New Mirror Volumes

- Because of Bad calculating the Mirror Size the creation of snapmirror Relationsships has failed

- Over the Hosts/Aggregate/Manage Space I have resized the Backup Node

- After the resizing the Relationship was created successfully, but since Then I Have the Behavior, which I have described above:

- Since I have resize The Mirror Node (over the Controller CLI) to a big Value (20TB) the snapmirror update works and only the Resize Error happen: