OnCommand Storage Management Software Discussions

Error with SnapMirror relationship

We are getting the error "XXXX is not a managed system. Add it through the main page to make it managed system" when we click on all destination relationships on specific controllers.  When this happens we do not get any of the details in the bottom pane and we do not have the abilty to edit the relationship.  The problem does not happen when we click the same relationship on the source side controller. Of course on the source side you can't perform operations so this dosn't help.  The point of bringing this up though is to show both sets of controllers are correctly configured in SM2.0.

We have four seperate HA storage solutions (8 controllers) and all of them are configured in System Manager 2.0. We have used SM2.0 to configure volumes and other things for all 8 conrollers.

For some reason this only happens on two of our controllers when we click on a destination SnapMirror relationship. To be clear if we click on any of the source relationships on any controller we don't have the problem and when we click the destinations on six of our controllers we don't see the problems. 

Has anyone seen this problem before?  



Re: Error with SnapMirror relationship

I see the same issue for the SnapMirror relationships on the destination filer for one particular source filer in SM 2.0 R1. I've noticed that the name of the source filer on the main page is in all capital letters whereas in the SnapMirror relationship it is in all lower case letters. I've tried removing and re-adding the source filer on the main page but it is always added in all caps and still get this error on the destination filer when viewing the SnapMirror relationship.

Re: Error with SnapMirror relationship

System Manager allows managing SnapMirror relationships seamlessly irrespective of source or destination system i.e you can perform all operations (source and destinaiton) either from source side or from destination side.

The pre-requisite for this is that both the source system as well as destination system needs to be added to System Manager main page. You need to also make sure that the hostnames of the systems that are displayed in the System Manager main page and the SnapMirror relationships are the same in terms of case

Re: Error with SnapMirror relationship

Those pre-requisites pose a problem then.  My customer has multiple VIFs.  The primary one the host name resolves to is the one they use for their CIFS shares. They use seperate one for SnapMirror.  As an example their system names are usmkna01a\usmkna01b and uschna01a\uschna01b.  The separate VIF they created only for SnapMirror on each system has "svif2" at the end.  As an example the one on usmkna01a is called usmkna01a-svif2.  So the SnapMirror relationship uses that name. 

All four systems, usmkna01a\usmkna01b and uschna01a\uschna01b, are configured in System Manager but by those primary host names. 

Are you saying we need to add the controllers to System Manager again by the name with the "svif2" in them? When you add one system it automatically adds the other. So if I added usmkna01a-svif2 how would it know to bring in the "b" controller using the "svif2" IP or DNS name rather than the base host name?

I see this as a problem for cusotmer's who use SnapMirror connection names.  If they want to use more than one path for SnapMirror for either multi-path or failover they must use a connection name for the SnapMirror relationship.  If they want to use SnapMirror compression the must use a connection name for the relationship.  The connection name won't be something that is resolvable to a single IP externally which is the whole purpose of the connection name.  So, how do you get those relationships to work.

Re: Error with SnapMirror relationship

My SnapMirror relationships were created using FilerView before SM 2.0 was released. In SM 2.0, I cannot make the case for the spelling the same. When I remove the filer and re-add it, it always adds in upper case no matter which case I use when I type in the name. I even made sure it is listed in lower case in the etc/HOSTS file on each of the filers. The only thing I haven’t done is delete the SnapMirror relationship and re-create it in SM 2.0. I really don’t want to have to do this.

Re: Error with SnapMirror relationship

The current version of System Manager does not support SnapMirror connections. So you will not be able to manage SnapMirror with connection names.

Regarding adding controllers by the name with "svif2", I am afraid it is not possible. Even if you add the controller with it's VIF IP address, only the primary host name gets added to System Manager main page instead of VIF hostname.

Re: Error with SnapMirror relationship

Did you try changing the hostname on the controller using the hostname command?

When you loging to the controller vai cli, you should be able to see the lower case hostname. Then when you add the system to System Manager, it will take the lower case name.

Re: Error with SnapMirror relationship

The filer runs CIFS and is part of an AD domain. Will changing the host name via CLI with the hostname command cause problems with CIFS?

Re: Error with SnapMirror relationship

Are there plans on changing this for the next release?  With DOT 8.1 eliminating FilerView I can't believe code was written to limit SnapMirror relationships in this way. 

I have many customers who separate SnapMirror traffic onto its own Network interfaces.  For those cusotmer's we use a DNS name that resolves to something other than the system host name. We always leave the system host name for the CIFS connections.  While I can change this going forward there is nothing I can do about the customers I have who already have the relationships built.

Looks like  a topic for Insight!

Re: Error with SnapMirror relationship

Changing hostname on the controller via CLI should not affect CIFS if it is configured in AD.

If dynamic DNS is enabled, it will automatically create a hostname to IP mapping when the hostname is changed. If it is not enabled, the system adminstrator might need to add the new hostname to IP mapping in the DNS table for any new CIFS share mappings.

Please contact your system adminstrator regarding DNS mappings.