OnCommand Storage Management Software Discussions

HELP - Cannot access WFA on my dev system

Hello ( yes I am in the class but i think i will post a thread on this subject )

I have a test system W2K8R2 ( physical - dual xeon, 32GB RAM, SSD and 5x500GB Raid 5 ) plus netapp storage available.

This server is a standalone system with OC 5.0.1 running.  I have downloaded WFA and I have the plug in ( WFA_OC5setup ); I installed them in the same order and took careful note of the directories they were installed in:

c:\program files\netapp\dfm"

OC 5.0.1 installed fine, WFA 1.1.1 seems to have installed fine although two points of interest:

  • it warned that port 443 was busy but allowed me to continue ( i am not running any other software that i am aware of - my firewall is off - flash is loaded on IE8 - all browsing protection is removed ) -- should be wide open.
  • second it tried to install into c:\program files (x86)\netapp ... etc.  I made sure WFA installed in c:\program files\netapp\wfa"

WFA_OC5 also tried to install in "c:\program files (x86)\netapp" and i forced it to install in c:\program files\netapp\dfm" ... again it seems to have installed correctly.

On accessing WFA ... i am using IE 8 with flash installed to my address from the same client and a remote client and both "connect" but then just sit and spin without loading the log in screen.

My goal is to use WFA on this system since it hosts a private OC server and access to stable storage controllers.



Re: HELP - Cannot access WFA on my dev system

Hello Emanuel,

Several thoughts:

First, the main one: WFA does need port 443.

The fact that we allow to continue is due to an older hindsight and will not be allowed anymore come 2.0.

Please uninstall WFA, make sure that port is available and re-install WFA, so our Webserver (JBoss)

will be able to register the port.

On the matter of co-hosting OC5 with WFA - It is doable, if you configure your ports the right way (Been done successfully before).

A small side-note is that if you plan to run dfpm commands or any dfm commands on the OC5, you'll need to put an SSH server

on the machine (See a ref in another thread to FreeSSHd or Cygwin's SSH).

On the matter of the installation path - WFA 1.1.1 is still a 32bit application (2.0 will feature a 64bit JVM), so the path automatically
chosen was indeed correct. However, the path you selected is fine and will offer no consequences :-)

Since all the rest seems fine - Please let me know if you need further assistance.


Yaron Haimsohn

WFA team

Re: HELP - Cannot access WFA on my dev system

Hello Yaron

On my host box ( which also is running a copy of VM workstation ) i may move both instances ( OC 5 and WFA ) to seperate VMs and use them together in that fashion.  After talking to some of the instructors, it could be that my W2K8 may have snuck in IIS or some other service which could be using 443. 

I will also attempt to get them working together on the same host because you never know what environments you may encounter in the field.

I will start this testing wednesday. 


Re: HELP - Cannot access WFA on my dev system

Bear in mind that WFA also needs PowerShell 2.0 and .net framework 3.5.

That last one brings back IIS. After the .net installation, be sure to remove the IIS role (Not a problem, windows will allow it).

Good luck!!

Re: HELP - Cannot access WFA on my dev system

Correct.  I removed WFA from my OC host and spawned a new W2k8 WM and had to perform the dance of loading flash, .net 3.5 ( powershell is already installed ) and .... SCORE!!!!

I have logged in and will be exploring more!