OCUM 6.1rc1 alert issues with Qtrees

I am trying to get alerts to work for Qtree almost full or full on a 8.2.1 cmode system and so far ocum 6.1rc1 is failing, however ocum 5.2 is alerting just fine.  What is not set correctly for alerts not to be created in ocum 6.1rc1?  I have setup notification settings and tested emails,  alerts for hardware failures are working fine.  I have gone so far as to create a separate alert with all qtree alerts in it to see if they would trigger by themselves.  I am still not being sent notices that the qtree is 96% full (luckily it is a test qtree so leaving it at this level for testing).  Attached are screen shots of the settings I have tried so far

Re: OCUM 6.1rc1 alert issues with Qtrees

Hi Tom,

The first screenshot(of OCUM global options) you pasted here is w.r.t the 'volume quota (almost) overcommitted' event that we get when committed quota space of all qtrees within a volume exceeds the volume space. It is unrelated to the 'qtree usage nearly full (or) qtree usage full' event that you expect here.  That quota limits(soft / hard) are totally determined by Ontap here.

Can you paste the o/p of 'quota report -vserver <vs> -volume <vs>' here?

Re: OCUM 6.1rc1 alert issues with Qtrees

Will get that in the morning, is that where I can have the client setup alerts?  I really needs some answers for the client soon.

Re: OCUM 6.1rc1 alert issues with Qtrees

Hi Tom,

In the third pic (quotaissue_3.jpg) we see Target resources missing

Can you please edit the alert and associate this resouces and recheck

And we also want to know if you have seen the tree quota related events in event grid before

Hope this helps


Re: OCUM 6.1rc1 alert issues with Qtrees

Interesting I had all the qtrees in their prior not sure why they were removed, and no I have never been alerted that a qtree is at 95% or higher, which is why I am confused on the alerts.

Re: OCUM 6.1rc1 alert issues with Qtrees

Here is that output:

cgynf1::> quota report -vserver cgynf1-nas05 -volume nas_p2_KVS05

Vserver: cgynf1-nas05

                                    ----Disk----  ----Files-----   Quota

Volume   Tree      Type    ID        Used  Limit    Used   Limit   Specifier

-------  --------  ------  -------  -----  -----  ------  ------   ---------


         KVS63     tree    1

                                  461.0GB  480GB  578339       -   KVS63


         KVS64     tree    2

                                  463.3GB  480GB  617566       -   KVS64


         KVS65     tree    3

                                  469.1GB  480GB  613094       -   KVS65


         KVS66     tree    4

                                  476.4GB  490GB  666769       -   KVS66


         KVS67     tree    5

                                  461.8GB  480GB  623676       -   KVS67


         KVS68     tree    6

                                  482.8GB  500GB  635710       -   KVS68


         KVS69     tree    7

                                  465.4GB  480GB  637784       -   KVS69


         KVS70     tree    8

                                  490.2GB  500GB  706740       -   KVS70


         KVS72     tree    9

                                  494.4GB  550GB  734155       -   KVS72


         KVS75     tree    11

                                  499.1GB  500GB  591856       -   KVS75

10 entries were displayed.

Re: OCUM 6.1rc1 alert issues with Qtrees

Thanks Tom,

I see the resources in-place now.Thanks for the screenshot and the command line output

1.Is Test alert working?

2.Can you upgrade your 6.1RC1 setup to 6.1GA build?

I remember a burt fix which went for quota between RC1 and GA. (i can get details if needed.)

I would recommend you to be on latest 6.1 build and check this.


Re: OCUM 6.1rc1 alert issues with Qtrees

Test alert worked fine, will work on getting upgraded to GA.  If you could send the link to that, or I will also look through the upgrade document for details as well.

Will try again after the upgrade but for now, no alerts on qtrees yet.

Re: OCUM 6.1rc1 alert issues with Qtrees

We have upgraded to 6.1GA and still no luck on qtree alerts. We have enabled quota and set the disk threshold to be 10% of the size of the qtree hard limit and it still does not alert.  Also is there a way to set the alert to 90% of the hard limit?  so we have a warning prior to it not being able to write to the qtree?

Re: OCUM 6.1rc1 alert issues with Qtrees

Hard and soft limits work on qtree, however they want the disk threshold alert to be set, is that an option?  We have it set but cannot find any way to alert or trigger an event in OCUM for disk threshold.