Re: OCUM 7.0RC1-Invalid links in Email Alert



I have the same problem here with OCUM 7 ESX applinace. I don't have a way to get to um command prompt.

Anybody have the fix for this issue?


Thank you!

Re: OCUM 7.0RC1-Invalid links in Email Alert

I had the same issue (localhost in links in the emails) and I was able to open a ticket with support and they were able to walk me through the steps quite easily (after we got it escalated a couple levels, that is). It involves a special mode accessed in the maintenance menu that gets you in as root that they only let you know about when you need support. So just open a ticket and they'll get you sorted out.

Re: OCUM 7.0RC1-Invalid links in Email Alert

Thank you! 

I just opened a case with them.


Re: OCUM 7.0RC1-Invalid links in Email Alert

hey cprivitere


i'm glad your support could help you in this case. Unfortunately I'm not that lucky for now.

Can you let me know how to get to this special root login?


Thanks, Michael

Re: OCUM 7.0RC1-Invalid links in Email Alert

ok just figured it out:


In the Main Menu, type 4 to select Support/Diagnostics.To access the diagnostic console, in the command prompt type erds.
You are prompted with the following message:Remote diagnostic access is disabled. Would you like to enable remote diagnostic access? (y/N).
Type y to enable remote diagnostic access.When prompted, enter a new UNIX password for the diagnostic user.Type x to exit from the maintenance console.
Log in to the maintenance console with diag as the user name and the new UNIX password that was set in Step 11.


thanks anyway, now all works fine for me.

Re: OCUM 7.0RC1-Invalid links in Email Alert

Works for me too.


Thank you!

Re: OCUM 7.0RC1-Invalid links in Email Alert



Thanks for your tipps...


I habe the OCUM installed on a windows Server, i found out i can do these commands in the adminstratos CMD

But the service ocie restart did not work, so i restarted the the whole Server


But my customer asked ma and he use the vsphere Appliance.

Do he have to login with ssh?? in console from vsphere client he just get the text emnu to use.


Thanks for more details ...


Regards from Switzerland .. Udo

Re: OCUM 7.0RC1-Invalid links in Email Alert

do the following 


ssh admin@ocum


 3 ) System Configuration


          11 ) Change hostname

          10 ) Reset Server Certificate


Re: OCUM 7.0RC1-Invalid links in Email Alert

The oc um command seems invalid in 7.2.


Main Menu
1 ) Upgrade (Disabled. Must be run on virtual machine console.)
2 ) Network Configuration
3 ) System Configuration
4 ) Support/Diagnostics
5 ) Reset Server Certificate
6 ) External Data Provider
7 ) Performance Polling Interval Configuration
8 ) Migrate Data from OnCommand Performance Manager 7.1

x ) Exit

Enter your choice: um cli login -u -p XXXXXXX

Invalid response.
OnCommand Unified Manager Maintenance Console


Ok, so lets try the menu, found a hostname entry:


System Configuration Menu
1 ) Display Server Status
2 ) Reboot Virtual Machine
3 ) Shut Down Virtual Machine (Disabled. Must be run on virtual machine console.)
4 ) Change 'admin' User Password
5 ) Increase Data Disk Size
6 ) Increase Swap Disk Size
7 ) Change Time Zone
8 ) Change NTP Server
9 ) Restore from an OCUM Backup
10 ) Change hostname

b ) Back
x ) Exit

Enter your choice: 10

This will change your hostname, which will reset your network connection
Hostname : nas-ocum-prod-1201


That is the correct hostname, but the emails still have localhost in the links. I just upgraded the system to 7.2, and the links came through properly before the upgrade, but now show localhost.
6:25 AM (8 minutes ago)

to techops-se
A risk was generated by localhost that requires your attention.

Risk - LIF Not At Home Port
Impact Area - Availability
Severity - Warning
State - Resolved
Source - nas_prod:nas-sea2-03-vmds
Trigger Condition - The current port nas-sea2-04:a0c-33 that is associated with the LIF is different from the home port nas-sea2-03:a0c-33.

Event details:

Source details:

Alert details:



Any ideas?

Re: OCUM 7.0RC1-Invalid links in Email Alert

Hi Aps,


the "um cli login" command does exist in UM 7.2, but you tried at the wrong place. You need to drop to the DIAG shell in order to do this.

Please follow the steps in this KB article to get to the DIAG shell:


The problem of the host being identified as "localhost" and its remidiation is described here:


regards, Niels



If this post resolved your issue, please help others by selecting ACCEPT AS SOLUTION or adding a KUDO or both.