OnCommand Storage Management Software Discussions

OnCommand System Manager 3.1RC1 for Mac OSX


The Mac build at toolchest has been updated to 3.1RC1 build.


System Manager 3.1RC1 build for Mac OSX is now available for download from NetApp Support Site > Toolchest


Disclaimer on OnCommand System Manager 3.1RC1 for Mac OSX


We currently do not officially support Systems Manager on the Mac OSX Platform.

This will be supported on a best-effort volunteer basis via the communities There is no engineering or CSS support for this build.

There will be no guarantee for support nor commitment to providing an OSX based client in future releases.


Thanks for supporting System Manager.

Message was edited by: Kunal Malhotra


Re: OnCommand System Manager 3.0 for Mac OSX

Nice, thanks!

Re: OnCommand System Manager 3.0 for Mac OSX

Awesome, thanks!


Re: OnCommand System Manager 3.0 for Mac OSX

Can it work on 10.7 as I tried to run it and it says I dont have 10.8

I have the latest Java installed.

Re: OnCommand System Manager 3.0 for Mac OSX

Thanks to who created the build and also the FAQ. Copy pasting some info -

1. What version of Java do I need?

System ManagerJava VersionNative in OSXNeed JDK

3.0+1.7.0< 10.7 - No
10.8+ - Yes on new installs only
Yes only if upgraded to 10.8. No for new install of 10.8

You can download JDK 1.7 from here.

2. I installed JRE 1.7.X but still SystemManager does not start?

The JRE version 1.7 that you download through the software update mechanism only updates java for the web browsers. If you need JAVA 1.7 for your programs, you need to update the native java installed in /usr/bin/java.

To check what version you are running natively open a Terminal and then type in

>> java --version

openjdk version "1.7.0-ea"

OpenJDK Runtime Environment (build 1.7.0-ea-b215)

OpenJDK 64-Bit Server VM (build 21.0-b17, mixed mode)

My version here is OpenJDK. This is the same as Oracle JDK but installed through the MacPorts package manager. Oracle JRE 1.7.x will also work.

Re: OnCommand System Manager 3.0 for Mac OSX

Go to the app, right click it and choose Show Content.

Open info.plist in text editor

Try changing 10.8 to 10.7.

Save it, close finder window and start the App.

Fingers crossed.

Re: OnCommand System Manager 3.0 for Mac OSX

I'm pleased to say, this version works on Mac OS X Mavericks 10.9 DP5.

And unlike previous versions released this opens in your default browser. In my case chrome.

Message was edited by: Martijn van Amerongen - Typo

Re: OnCommand System Manager 3.0 for Mac OSX

Tried changing to 10.7. Does not work.... .. Tried double click on system manager and nothing happens ..

java version "1.7.0_25"

Java(TM) SE Runtime Environment (build 1.7.0_25-b15)

Java HotSpot(TM) 64-Bit Server VM (build 23.25-b01, mixed mode)

Re: OnCommand System Manager 3.0 for Mac OSX

I had the same issue at first then noticed that the java.com download is for JRE 1.7 not JDK 1.7 by default to get the runtime environment instead of developer kit... I had to go to downloads and install JDK 1.7 then all worked great.

Re: OnCommand System Manager 3.0 for Mac OSX

I verify that I have installed JDK 1.7 and not JRE 1.7.  But its still not working Guess that's the problem with Java ....

ls -l /Library/Java/JavaVirtualMachines

total 0

drwxr-xr-x  3 root  wheel  102 16 Aug 09:24 jdk1.7.0_25.jdk

JDK is installed ...

OSX : 10.7.5

.... on deeper investigation, I check the console .. and its say ...

13-08-29 1:26:08.432 AM com.apple.launchd.peruser.501: ([0x0-0xe80e8].com.miracent.SystemManager3[5608]) Job appears to have crashed: Segmentation fault: 11

Process:     launchd [5671]
Path:        /Applications/SystemManager3.app/Contents/MacOS/SystemManager3
Identifier:  com.miracent.SystemManager3
Version:     ??? (???)
Code Type:   X86-64 (Native)

Parent Process:  launchd [218]

Date/Time:   2013-08-29 01:30:52.761 -0400
OS Version:  Mac OS X 10.7.5 (11G63)

Report Version:  9

Sleep/Wake UUID: 2BF48F1C-1647-4C60-9492-0CFDD74727D5

Crashed Thread:  Unknown


Exception Codes: KERN_PROTECTION_FAILURE at 0x00007fff5fc01028

Backtrace not available

Unknown thread crashed with X86 Thread State (64-bit):

  rax: 0x0000000000000055  rbx: 0x0000000000000000  rcx: 0x0000000000000000  rdx: 0x0000000000000000

  rdi: 0x0000000000000000  rsi: 0x0000000000000000  rbp: 0x0000000000000000  rsp: 0x0000000000000000

   r8: 0x0000000000000000   r9: 0x0000000000000000  r10: 0x0000000000000000  r11: 0x0000000000000000

  r12: 0x0000000000000000  r13: 0x0000000000000000  r14: 0x0000000000000000  r15: 0x0000000000000000

  rip: 0x00007fff5fc01028  rfl: 0x0000000000010203  cr2: 0x00007fff5fc01028

Logical CPU: 2

Binary images description not available

External Modification Summary:

  Calls made by other processes targeting this process:

task_for_pid: 1
thread_create: 0
thread_set_state: 0

  Calls made by this process:

task_for_pid: 0
thread_create: 0
thread_set_state: 0

  Calls made by all processes on this machine:

task_for_pid: 11273
thread_create: 1
thread_set_state: 0