OnCommand Storage Management Software Discussions

SnapDrive on Windows 2008

I am trying to install SnapDrive 6.0 (x64) on a Windows 2008 server. I get through all of the pre-install questions, but as it is nearing the end of the installation process, it throws up this error that I can't seem to overcome.

"Error 1923.Service SnapDrive (Swsvc) could not be installed. Verify that you have sufficient privileges to install system services and check your Event Log for more information."

The Event Logs of course give the same error without any further explanation. I tried logging into the server as a domain administrator and I also tried doing a "Run as administrator" on the install file, but I get the same error each time. I tried to Ignore the error instead of Aborting it and it failed again when it tried to Start the SnapDrive service and mentioned insufficient privileges.

Has anybody had success installing SnapDrive 6.0 on a Windows 2008 server?


Re: SnapDrive on Windows 2008

Hey Aaron,

Welcome to UAC issues with Windows Server 2008!

You have a few options to work around this issue:

1. Temporarily disable UAC (User Access Control) which will allow the installer to run as the Administrative user you're working with.


2. Launch the installation from a command shell which has already been elevated to an Administrative account.

Most people typically go route #1, I personally tend to go route #2 just because I've been dealing with UAC type issues for years.

Let us know if that helps with what you're trying to do!

Also, if you run into an issue where you get a certificate issue (if this particular host does not have Internet access) you may want to opt for installing 6.0P1 version of SnapDrive.

Thanks Aaron!


Re: SnapDrive on Windows 2008

nice topic..

will take note of this one in my future implementations ..

Re: SnapDrive on Windows 2008

Thanks for the reply, Christopher. Unfortunately UAC doesn't seem to be the problem. I did check and confirm that User Account Control on this particular server is off. I have been logging into the server (remotely via Remote Desktop) with a Domain Admin account.

Also, I tried the "change user /install" command and it said that "Install mode does not apply to a Terminal server configured for remote administration." so I know that is setup correctly as well.

Again, I tried right clicking on the install file and selecting "Run as administrator", but that did not work either. The server does have internet access, so I have not run into any kind of certificate issue I don't believe.

I'd be happy to try a more recent version of SnapDrive than what I have if you think that might help (I am using SnapDrive6.0_x64), but would need direction in where to download it from.

Re: SnapDrive on Windows 2008


I discovered the problem and thought I would add it here. As it turns out, the newly created Service Account wasn't added to the server's Administrator Group. I had to go into the Local Users and Groups manager and add the service account I was using to the Administrators group. The user was already displaying, it just hadn't been added to the local admin group.

Thank you for your assistance, hopefully this resolution to the oversight on my part will help anyone that runs into the same frustration.


Re: SnapDrive on Windows 2008

Thank you for the feedback Aaron,

Also for anyone who references this in the future:

Check out the SD6 Admin Guide (Page 44) This will include references to what security settings and account information you'll need for both a local account as well as accounts on the filer, whether you're using RPC or HTTP/HTTPS for authentication.

Glad you got it taken care of!


Re: SnapDrive on Windows 2008

This also applies to Windows 2003. Quick note as well, when configuring pass-through authentication (i.e. the same local account on the filer and server) make sure to specify the computer name with a backslash before the username or use the GUI to select the local account. It may be in the documentation, but in my haste I ran into the same error. Just though I'd share in case anyone else has the same problem.


Re: SnapDrive on Windows 2008

Hi Robert

It seems like you've configured snapdrive with pass through authentication. I've done the same on my Windows 2008 X64 server. When I bring up the snapdrive console and selct Disks - create disk, I get access denied. I had created the snapdrive account as a local user account on the Windows server and added it to the local administrators group. I also created a local snapdrive account on the filer and added it to the BUILTIN Administrators group on the filer. Yet, I get access denied.

I've gotten pass through to work (years ago) on a Windows 2000 or 2003 server. I'm thinking this is an issue with 2008. Did you install on Windows 2008? Could you share your steps of configuring pass through authentication?