OnCommand Storage Management Software Discussions

Storage Efficiency Dashboard

Hey Guys,

I'm trying to get omeff installed on my new linux dfm server... I run through the install as described on the download page... ('dfm script add omeff_linux.zip' as well 'chmod +x /opt/NTAPdfm/script-plugins/dfmeff/dfmeff')

The permissions are as follows...

[root@dfmserver script-plugins]# ls -l

drwxr-xr-x 3 root root    4096 Apr 19 09:07 dfmeff

[root@dfmserverdfmeff]# ls -l
total 10756
-rw-r--r-- 1 root root    3371 May 17  2010 Application.js
-rw-r--r-- 1 root root   55093 May 17  2010 Column2D.swf
-rw-r--r-- 1 root root   10204 May 17  2010 dashboard.html
-rwxr-xr-x 1 root root 9768910 May 19  2010 dfmeff
-rw-r--r-- 1 root root     834 May 17  2010 down.png
-rw-r--r-- 1 root root   14015 May 17  2010 FusionCharts.js
drwxr-xr-x 2 root root    4096 Apr 19 09:07 jobs
-rw-r--r-- 1 root root       0 May 17  2010 license
-rw-r--r-- 1 root root   56991 May 17  2010 netapp.png
-rw-r--r-- 1 root root  948781 May 17  2010 nwf_splash.png
-rw-r--r-- 1 root root     587 Jul 29  2010 package.xml
-rw-r--r-- 1 root root   56965 May 17  2010 Pyramid.swf
-rw-r--r-- 1 root root   42900 May 17  2010 SSGrid.swf

when I manually run the script, it errors out and I get the following error:

/opt/NTAPdfm/script-plugins/dfmeff/dfmeff: error while loading shared libraries: libldap-2.4.so.2: cannot open shared object file: No such file or directory

Is there somehtign i'm missing with the install... Can someone point me in the right direction here?  

Thanks a lot!


Re: Storage Efficiency Dashboard

What make and version of Linux are you running your DFM server on?

Re: Storage Efficiency Dashboard

it is looking openldap  2.4

you  could create a link simillar . it not a good soluation unless  if you install 2.4 version of openldap

ln -s /usr/lib/libldap-2.2.so.7 libldap-2.4.so.2


Re: Storage Efficiency Dashboard


source <dfm-install-dir>/bin/vars.sh

and then try.

Re: Storage Efficiency Dashboard

rhel 5.6 and dfm 4.0D24

Re: Storage Efficiency Dashboard

I ran 'source /opt/NTAPdfm/bin/vars.sh' ... tried to re-run the script and get the same error complaining about 'shared libraries: libldap-2.4.so.2'.

is this something that should be installed with rhel or is it an rmp to run after???  I’m a Windows guy, this is new territory for me.

Re: Storage Efficiency Dashboard

I was attempting to get the dashboard running on 4.0D24, as posted, I had no success....  I just ran the upgrade to DFM4.0.2 and it's now working. 

Re: Storage Efficiency Dashboard

Version 1.3 is available for download. Which works with OnCommand 5.0 and 64bit machines.Below is the link to the same.




Re: Storage Efficiency Dashboard

For 1.3 version I get following error.

tail 56446.out

/opt/NTAPdfm/script-plugins/dfmeff/dfmeff: error while loading shared libraries: libssl.so.0.9.8: wrong ELF class: ELFCLASS32

and for 1.2 version I get similar error like OP

We are using 4.0D23 on Linux RHEL 5.5. Any ideas?

Re: Storage Efficiency Dashboard

Version 1.3 only works with OC5.X.  It will not work with DFM4.X.