OnCommand Storage Management Software Discussions

Unable to load VMware Poweshell Snapin

Hi All,

I installed the WFA version and now I am facing some problems to create the datasource to connect in vCenter.

I inserted the hostname, username, password, database (VIM_VCDB), but when I try to acquire the data I am receiving the error "Unable to load VMware Poweshell Snapin"

Does anybody know how to solve this problem ?

Thanks in advance,

Vinicius Calori

Systems Engineer @ Brazil


Re: Unable to load VMware Poweshell Snapin


Did you install the PowerCli package from VMware?

It is not installed by default, as stated in the installation guide.



WFA Team

Re: Unable to load VMware Poweshell Snapin

I loaded the PowerCli Package on the WFA server and still get the same result. I can launch PowerCli, so I know it's working.

Is there some other step to perform to make sure this is working for WFA and vCenter?

Re: Unable to load VMware Poweshell Snapin

Are you running PowerCLI 5.1 build 1012425?  This was a bug in their Environment script which is what is being called by WFA.  Also, make sure that you enable "Set-ExecutionPolicy –ExecutionPolicy RemoteSigned" in your PowerCli window

Steps to fix issue with build 1012425

  1. Navigate to the following directory path on the WFA server  -- "C:\Program Files (x86)\VMware\Infrastructure\vSphere PowerCLI\Scripts\"
  2. Right Click the file named - Initialize-PowerCLIEnvironment.ps1 and select properties.
  3. Remove the ReadOnly flag and hit ok
  4. Edit the file named - Initialize-PowerCLIEnvironment.ps1
  5. Remove line # 9 - "$version = Get-PowerCLIVersion". This command will never run fails WFA every time.
  6. Save the file

Jeremy Goodrum, NetApp

The Pirate

Twitter: @virtpirate

Blog: www.virtpirate.com