OnCommand Storage Management Software Discussions

WFA install

Hi all,

is there a way to specify different ports during/after the intall of WFA?

=> specifically for the ports 80 & 443...

(for test purpose, I installed WFA in the same VM as OC5...)

thanks in advance



Re: WFA install

This guess should be possible by adjusting the jboss configuration but I haven't tried this myself so I can't provide any description

I also haven't tried to run WFA in parallel to OC5 but I wouldn't expect problems (although it isn't best practise) as OC5 runs its webserver on port 8080 while WFA runs on port 80. Are you running into any specific problems due to port conflicts?



Re: WFA install

There is no way currently to specify different ports.  WFA requires port 80 and 443 for HTTP and SSH.  As Hendrik mentioned, it is recommended to install WFA on it's own VM, and not on the same VM as OC5.  That said, it is possible, and others have done this for a testing / lab configuration.  We strongly advise separate VM's when using WFA in a live capacity.



Re: WFA install

Hi Yves,

As per our chief architect it is possible and a manual procedure can be supplied. Don't know how much it was tested,

but it should be possible.

Regardless, we highly recommend not to co-host WFA with OC, unless it is strictly for lab testing.

When WFA needs to run commands on the OC, it happens mostly over SSH. That would require

sshd installed and is not that recommended (Though working).

Best regards,

Yaron Haimsohn

WFA team

Re: WFA install

Hi all,

the problem we are facing is that WFA does not start... (in fact, http://a.b.c.d/WFA gets nowhere)

I guess we ll try on another platform

thank you all!


Re: WFA install

Hello Yves,

2 things to check:

1) Our URL is case sensitive so its http://a.b.c.d/wfa

Can you confirm that?

2) There's a rare but known issue with WFA not starting correctly. Copying test information from tips and troubleshooting guide:

WFA should start automatically after installation and should be available for use in 1-2 minutes.

If that’s not the case, verify that log files were created under the log folder (ie c:\Program Files(x86)\Netapp\WFA\JBoss\server\default\log).

If there are no log files (Specifically no server.log) in the directory – Kindly contact us for manual override details.

Can you please confirm if that's the case?



Re: WFA install

Hi Yaron,

the URL was the right one.

the server.log was full of JBOSS warnings & errors though... (unrecognized windows socket... failed to load profile... missing dependencies...)

Anyway, WFA was reinstalled in its own private VM, & now it works perfectly

thanks for all the help