'dfm host add' snmp issue

Hi Guys,

Just came across an error when adding a filer to my new DFM server... it's telling me that the DFM server can't communicate to the filer using snmp.  If you see the CLI outputs below, you can see that snmp_v1 and v3 are failing.  I’ve checked the filer and 'snmp.enable’ is set to ‘on’ as well all other snmp setting are set to match my other filers.

#dfm host add <filer>

Error: Can't contact new host <filer> with SNMP or host agent protocol.

For host agents, make sure that host agent is installed and running on the

host. For other hosts, make sure SNMP is enabled on the host.

Run 'dfm host diag <filer>' to troubleshoot.

#dfm host diag <filer>

Network Connectivity
IP Address             <ip_address>

Network                (discovery disabled)
DNS Aliases            <filer>

DNS Addresses          <ip_address>

SNMP Version in Use    SNMPv1
SNMPv1                 Failed: Timeout
SNMP Community         public
SNMPv3                 Failed: Timeout
SNMPv3 Auth Protocol   MD5
SNMPv3 Privacy Enabled Yes
SNMPv3 Username        root
ICMP Echo              Passed (1 ms)
HTTP                   Passed (1 ms)
Host Agent Connect     Failed (transport http; port 4092)

Anyone have any ideas as to what could cause this?



Re: 'dfm host add' snmp issue

Hi Scott,

Is there a firewall on the DFM server or on the network between the Storage System in question and the DFM server ?

SNMP uses ports 161/162 /UDP to communicate



'dfm host add' snmp issue

A couple of things come immediately to mind:

1) Firewalls, either local on your server or somewhere in between

2) multiple IP aliases in the same subnet as the one you are polling on the filer

3) options snmp.access does not include your dfm server

'dfm host add' snmp issue

Hi Rich,

There are now fw's between the dfm server and the filer.



'dfm host add' snmp issue

There are no fw's between the dfm server and the filer in question....

The filer does have 2 vifs however; I've been specifying the ip address for the vif I setup as the preferred interface

snmp.access = legacy

The funny part is that 2 minutes after I posted, I tried again and for whatever reason this time it added the host. The only follow up issue is that it still shows snmp as failed during a host diag.....

Re: 'dfm host add' snmp issue


The only follow up issue is that it still shows snmp as failed during a host diag.....


I don't know why this happens but I often see that IP configured to vifs, vlan interfaces take longer time in reaching. This is what I suspect here. No certain as yet though. Can you try to increase the SNMP timeout and SNMP re-tries to some larger value.

On CLI something like this:

# dfm option set monSNMPTimeout=500

Changed SNMP timeout (in seconds) to 500.

# dfm option set monSNMPRetries=100

Changed SNMP retries to 100.


Now refresh the host and see if it works.

warm regards,


If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

'dfm host add' snmp issue

If you have made any changes to the SNMP communities via filerview, back them out and make the changes from the CLI.  I have seen filerview changes never take effect even after options snmp.enable off then on and snmp init.

Re: 'dfm host add' snmp issue

Was actually wondering if you ever solved this issue.

We had the same issue with our filers and found out the the community string on the filer or the DFM server it self was incorrect. We changed these settings so that they matched and things worked just fine.

Was just curious.