Simulator Discussions

OnTap 8.1.4 7-mode VMware Workstation Network Settings Help

Hi All,

I have the OnTap Simulator v8.1.4 7-Mode running on my VMWare Workstaion Pro.  I have the netapp simulator configured correcly from an "OnTap" perspective for the regular setup values, network IP, subnet, gateway, dns, etc.

 

I'm confused on what my settings should be for the VM Network adapters ad whether I should be using Bridged or Host-Only; and on what adapters for these.

 

In My Virtual Network editor I have the following (by default):

VMnet0 - Bridged (Auto-Bridging) with no Host connection, DHCP or subnet Address

VMnet1 - Host-Only - with no external connection shown, Host connection shows Connected no DHCP, shows a Subnet Address

VMnet3 - NAT, NAT, Connected, DHCP Enabled, shpows a Subnet address

 

In my Sim VM settings:

Network Adapter #...

1  Host-Only

2 Host-Only

3 NAT

4 NAT

 

I can ping myelf (Sim VM)

I cannot ping anay other IP's outside of the SIM (nor by name).

 

I'm greatful for any assistance as this is out of my VM knowledge realm even though I'm very verse in OnTap.

Thanks in advance,

Ed

 

3 REPLIES 3

Re: OnTap 8.1.4 7-mode VMware Workstation Network Settings Help

Hi There!

 

You probably want bridged for all of them - that means your VM will be on your LAN just like your Windows host.

 

Hope this helps!

Re: OnTap 8.1.4 7-mode VMware Workstation Network Settings Help

For a 7mode sim, I usually connect all the ports to NAT.  Use the gateway from the VMware networking settings.  By default its going to put e0a/e0b on "hostonly", which is more appropriate for a cdot sim.  I never understood the rationale behind defaulting 7mode sims to a cmode network topology. 

 

You could also use bridged to connect directly to the outside network, but if its not a network you control get whoever does to assign you the extra IP(s) for your vsim.

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

Re: OnTap 8.1.4 7-mode VMware Workstation Network Settings Help

Thank you to all who replied back to me with their suggestions and insight.  Here's is what I had to do to resolve this issue: 

The VSim comes preconfigured for 4 NIC's.  I trimmed this back to 1 NIC and set it to Bridged.  Even after that I still could not get any further than my ESX VM Host server.  After tinkering with it some more, we found that I had to enable Forged Transmits and Promiscuous Mode on the Test port group in vSphere to let the VSim traffic be able to pass through. 

If this is not enabled, the simulator will not connect to the outside network at all as the forged transmits/promiscuous mode settings will block any transmissions from the VMware Workstation instance.   While enabling this is not an ideal resolution, I took it one step further and isolated the VM to one host, set up a separate port group on the NIC on that host.

 

The only caveat is that it removes the network redundancy for that 1 host, but it isolaes the security risk down to just one VM.  Once we're finished testing with the VSim, we'll remove the port group and set up NW teaming again and disable the FT/PM again.

 

Thanks,

Ed

Forums