The community will be undergoing maintenance soon, requiring Read-Only mode. Click to learn more.

Software Development Kit (SDK) and API Discussions


 So I am working with some automation using Ansible and the NetApp Modules
 the one I am using is na_ontap_info
 and whenever I ran a task with that module, I get this error:
 NetApp API failed. Reason - 401:basic auth failed
 So I checked the account that I am using via SSH and it is working
 and also checked it has console, ontapi and ssh access
 but still not working


You need to use localhost and https to communicate.


Here is an example of ad-hoc ansible command.


"ansible localhost -m na_ontap_info -a "hostname= username=admin password=Netapp01 https=true validate_certs=false"


Please replace the hostname with your cluster management IP, and same for username and password to see if it works.

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner