SolidFire PowerShell Discussions


PowerShell connect cluster issue

Hi, myself and at least one other customer has run into the following;


PS C:\Users\user-xxx> Connect-SFCluster -Target

cmdlet Connect-SFCluster at command pipeline position 1

Supply values for the following parameters:

(Type !? for Help.)



Connect-SFCluster : An error occurred during the request.

At line:1 char:1

+ Connect-SFCluster -Target

+ ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

    + CategoryInfo          : NotSpecified: (:) [Connect-SFCluster], ConnectionException

    + FullyQualifiedErrorId : SolidFire.Core.Exceptions.ConnectionException,SolidFire.Connection.ConnectSFCluster


I did observe this connected on VPN (on my laptop) to our vPOC labs. Customer, also on his laptop above when connected to VPN to their environment.
Customer also reports its not working even if remote desktop to a server local to his environment and run PS locally (still on VPN when connecting to the server though).


I have not tried that myself or had the chance to connect to a system on corp net (without VPN).

Ideas welcome, I want to show off the new stuff when demoing and this sorts of break that. 😉





Re: PowerShell connect cluster issue

There used to be a bug like this but it was resolved. 


Might be a firewall or route or some other network or connectivty issue. 

You can try the workaround from the bug report if you run into this again.



Re: PowerShell connect cluster issue

Thanks, I looked at that but makes no difference. However... 


I tried with the version from a local host inside vPOC environment (still connected to it via VPN --> Remote Desktop) and it works. So likely there is something network related as mentioned.

I still think it we need to figure out why it doesnt seem to work directly from my laptop over VPN though. Especially since a partner has the same issue on their own VPN-to-partner network.


While I can do a lot of testing and demoing using the Remote desktop option its not ideal, being able to run it locally is much preferred.


I'll try a few other things and see if it changes anything...



EDIT: Could this be a network port thing? If so, what ports are being used?


Re: PowerShell connect cluster issue

For reference, it's a Curl-related bug that impacts SSL connections (for many packages, not just SolidFire PowerShell Tools).

View solution in original post

Check out the KB!
NetApp Insights To Action
All Community Forums