Active IQ Unified Manager Discussions

NetApp-Harvest 1.4.1: Hotfix to fix 2 bugs


Dear Harvest community,


We have a hotfix for two bugs that we found in Harvest. If you are using Harvest 1.4.1, please run the hotfix as per the instructions below. If you use older version of Harvest, please first upgrade to 1.4.1, then run the hotfix.


The hotfix will fix:

  • BUG missing normalization of wafl_block in gb_per_sec (kuddos to @yannb for finding and solving this)
  • BUG miscalculating link_speed which breaks ethernet port utilization statistics.

Please download the hotfix file from here.

Then, follow these instructions:


1. Copy the file to /tmp/ (or any other folder) on your Harvest server.
2. Stop Harvest
3. Run the file:
If Harvest is installed in default location (/opt/netapp-harvest/), simply run in terminal: $ ./harvest_hotfix_14100 If otherwise Harvest is in another location, provide Harvest path as argument, e.g.: $ ./harvest_hotfix_14100 /home/admin/netapp-harvest/ 4. Read the output and see if the update was successful 5. Restart Harvest


The hotfix requires Python 2 or higher and write/execute priviliges in the Harvest directory.


Let me know if it worked out for you.


All the best,





fixed my missing ethernet stat issue 



I applied the 4.1 hot fix and it did fix ethernet stats on all my 9.3P8 kit but i have 4 clusters of 9.4P2 where  i get not data for ethernet  other status seem to work   please advise?




I applied the hot fix to my 3    4.1 installs and fixed all my 9.3P8  missing ethernet stats    however we just brought online  4 new 9.4P2 clusters and i have no ethernet stats  , other stats seem to work.    please advise?


I applied the 1.4.1 hot fix,     this fixed ethernet stats on all my  Ontap 9.3P8 kit but i still do not have ethernet stats for ontap 9.4  ?

Do you still have the same issue? Can you send me a screenshot if that's the case?

Looks like you'll need to renew the link you provided earlier as it has expired.


The link was set to expire after a certain amount of time. Please contact the person who shared this link with you.

Updated. Thanks!



I've tried to install patch but I get  "Couldn't verify Harvest status. Are sure Harvest is stopped?"  Even the pollers are stopped.


What shoud I check?



The same message came for me, so I double checked if any netapp-harvest processes are running:

ps faux | grep harvest

...and simply answered with yes. The Hotfix was applied without any problems and I could start netapp-harvest again.

Omg, sorry I was just a little bit lazy, I've typed only Y instead of YES, now working fine:


root@/tmp# ./harvest_hotfix_14100
Couldn't verify Harvest status. Are sure Harvest is stopped?
[yes/no]: yes
Check Harvest release [1.4.1]. OK.
Check source [plugin/cdot-nic-common]. OK.
Check source [netapp-worker]. OK.
Made backup copies to [/tmp/harvest_1544181049].
Updated [plugin/cdot-nic-common].
Updated [netapp-worker].
Updated changelog [CHANGES.txt].
Patch successful. You can now restart NetApp Harvest.


Need help to renew the link as it has expired.

Message as below
The link was set to expire after a certain amount of time. Please contact the person who shared this link with you.


Many thanks


I updated the link. Thanks!


Hi Vachagan

Download test ok!

Many Thanks.





How to run the hotfix in NAbox 2.4.2 ?

Check the NAbox Python is version 2.7 not version 3 .

Is this the problem?


Hi, you are right. I added a version of the patch for Python2 here. Goodluck!




It work thanks~



Hello Vachagan,


Could you please update the download links for the hotfixes.

I facing the  miscalculating link_speed which breaks ethernet port utilization statistics BUG.


Thank you

I updated the link, thanks for notifying.

We have harvest runing 1.4.2-1 (upgraded from 1.4.1) version which said to have this hotfix. But, i still see network utilization showing wrong value.


[root@harvest-01 netapp-harvest]# rpm -qa | grep harvest


Please find the attached screenshot of one of the node's port utilization percentage. 



Can you please let me know what could be the reason and how we can rectify it?


I just updated to 1.6 of harvest.  I'm still seeing port utilizations in the 1000's%.  Does this Fix apply to 1.6?


--- update. log out of graphana and clear browser cache and all is well