Active IQ Unified Manager Discussions

Slow workflow execution

francoisbnc
16,138 Views

I wonder why workflow execution is so slow at the first line of a command 2 minutes in this exemple with WFA 2.2 (same behavior with 2.1 version) without LDAP auth.

11:45:36.381 INFO  [Create volume] ### Command 'Create volume' ###

11:47:12.276 INFO  [Create volume] Executing command: ./Create_volume8173598297431862987.ps1 -AggregateName 'sas_t2_002' -Array '10.139.32.11' -Size '1000' -VolumeGuarantee 'none' -VolumeName 'test'

11:47:12.744 INFO  [Create volume] Get-WfaCredentials -Host 10.139.32.11

11:47:12.900 INFO  [Create volume] Credentials successfully provided for '10.139.32.11'

11:47:13.103 INFO  [Create volume] Connect-NaController (with credentials) -Name 10.139.32.11 -Timeout 60000 -ErrorAction Stop

11:47:24.662 INFO  [Create volume] Connected to controller

11:47:24.927 INFO  [Create volume] Creating a new volume - name 'test' , aggregate name 'sas_t2_002' , size '1000m' , volume guarantee 'none'

11:47:34.147 INFO  [Create volume] Command completed, took 117735 milliseconds

My productive wotkflows take more than 30 minutes just for cloning 5 volumes and mapping luns inside to igroup.

Any suggestions appreciate.

François

1 ACCEPTED SOLUTION

jcbettinelli
15,142 Views

Salut François,

We had such kind of issue with SnapManager Service for one of our customer.

There is an option in Internet Explorer called "Check for publisher's certificate revocation". I'm wondering if this option could help as well in your problem.

If this is enable, some programs needs an internet access.

That would be nice if you could give it a try

Cheers,

JC

View solution in original post

49 REPLIES 49

sinhaa
5,689 Views

Francois,

 

         Run the .NET repair tool and see if it helps.

 

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

stevenj
6,388 Views

Francois,

What exactly did you change within your server to get the workflow to speed up? Are you talking Internet settings (as in the proxy setups in IE, etc)?

francoisbnc
6,388 Views

Hello stevenj,

In my case WFA service was running with an active directory account, because I use some workflows commandlet that needs credentials, as get-service for exemple.

So I had to login interactively  with this service account and set proxy setting or set via regedit the correct HKEY_USERS Keys

[S-1-5-21..........\Software\Microsoft\Windows\CurrentVersion\Internet Settings]

"MigrateProxy"=dword:00000001

"ProxyEnable"=dword:00000001

"ProxyHttp1.1"=dword:00000000

"ProxyServer"="http://ProxyServername:80"

François

jcbettinelli
15,143 Views

Salut François,

We had such kind of issue with SnapManager Service for one of our customer.

There is an option in Internet Explorer called "Check for publisher's certificate revocation". I'm wondering if this option could help as well in your problem.

If this is enable, some programs needs an internet access.

That would be nice if you could give it a try

Cheers,

JC

francoisbnc
6,388 Views

Hi jc,

You are totaly right.

Removing Check for publisher's certificate revocation fix the problem as well.

François

stevenj
6,388 Views

Was this done on the workstation that the workflows were executed from or on the server? What user account? Still seeing issues with the workflows taking about 45 seconds to load the powershell modules.

stevenj
6,388 Views

Ignore - Read the response.... Changed the setting under the user that runs the WFA Server Service and dropped the load from 45 seconds to under 2 seconds.

Thanks!!

elic_co
6,215 Views

Hi all.

Tried to do all the examples shown and still takes long time like other posts.

 

Tried to change the "revocation" setting in Internet Explorer, tried creating the powershell.exe.config file with relevant configuration, also tried removing executor="http-executor" from xml file and restarting service,  and server is already 2008R2.

 

Any other ideas?

WFA Server service runs with local system.

 

Thanks.

Public