Data Backup and Recovery

Cannot delete SMO profiles

falarkiko10

Hi!

I'm installing SMO infraestructure and now atfer the laborotory test I have one doubt about profiles.

 

I had one SMO_TEST repository, after test the application y I installed new SMO_PROD repository in new server and BBDD and delete the SMO_TEST repository.

Now when I run this command from one of test servers (not from SMO database resides): smo profile list this is the output.

 

Profile name: SMO_TEST_SRV1 (Originaly created in SMO_TEST Catalog)
Profile name: SMO_PROD_SRV1 (Originaly created in SMO_PROD Catalog)

Profile name: SMO_TEST_SRV2 (Created in SMO_PROD but also its was created with the same name in SMO_TEST Catalog)

 

I see two profiles, the old and new but the old database is deleted and the server offline. ¿Is there any way to remove the old registry and SMO_TEST repository?

 

If I run this other command : smo profile sync -repository -dbname SMO_PROD -host 192.168.1.1 -port 1529 -login -username repo this is the output

 

[ INFO] SMO-20010: Synchronizing mapping for profiles in repository "repo@SMO_PROD/[192.168.1.1]:1529".
[ INFO] SMO-20011: Loaded mapping for profile "SMO_PROD_SRV1".
[ERROR] SMO-20009: Profile name "SMO_PROD_SRV2" in repository "repo@SMO_PROD/192.168.1.1:1529" clashes with profile name "SMO_PROD_SRV2" in repository "US_NETAPP@SMO_TEST/192.168.1.2:1529".
[ERROR] SMO-20013: Errors while synchronizing profiles from repository "repo@SMO_PROD/[192.168.1.1]:1529": [SMO-20009: Profile name "SMO_PROD_SRV2" in repository "repo@SMO_PROD/192.168.1.1:1529" clashes with profile name "SMO_PROD_SRV2" in repository "US_NETAPP@SMO_TEST/192.168.1.2:1529".]
[ERROR] SMO-01104: Error invoking command: SMO-20013: Errors while synchronizing profiles from repository "repo@SMO_PROD/[192.168.1.2]:1529": [SMO-20009: Profile name "SMO_PROD_SRV2" in repository "repo@SMO_PROD/192.168.1.1:1529" clashes with profile name "SMO_PROD_SRV2" in repository "US_NETAPP@SMO_TEST/192.168.1.2:1529".]

 

Thanks

1 ACCEPTED SOLUTION

Sahana

Hi

 

It may be due to Identically named profiles. Refer row 4 in the link https://library.netapp.com/ecmdocs/ECMP1354396/html/GUID-6FA823DD-6655-49E6-B9C4-DDE7CFA865A6.html

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

3 REPLIES 3

falarkiko10

Thanks Sahana

 

I've performed what you indicated to me but the profiles references have not been deleted.

 

In the SMO Java console I only view the correct repository repo@SMO_PROD and associated profiles SMO_PROD_SRV1

 

But if I execute this command smo profile list -verbose in one AIX host that SMO is installed the result is:

 

Profile name: SMO_TEST_SRV1
Profile name: SMO_PROD_SRV1

Profile name: SMO_TEST_SRV2

 

Where SMO_TEST_SRV1 and SMO_TEST_SRV2 are the profiles of old repository that doesn't exists.

 

Thanks

Sahana

Hi

 

It may be due to Identically named profiles. Refer row 4 in the link https://library.netapp.com/ecmdocs/ECMP1354396/html/GUID-6FA823DD-6655-49E6-B9C4-DDE7CFA865A6.html

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.

View solution in original post

Sahana

Hi

 

Try to clear cache in SMO GUI. Navigate to Menu -> Admin -> Credentials -> ClearCache

Reconnect to server and the repository & try syncing again.

If this post resolved your issue, help others by selecting ACCEPT AS SOLUTION or adding a KUDO.
Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public