Data Backup and Recovery

Clone_database created database with wrong name.

Mayur_Shelke

Hi All,

 

We regularly create database snapshots using SMSQL. We have recently found one strange issue with database creation. We use below command to create db clone.

 

clone-database –svr 'servername' –inst 'servername' -d 'PROD_DB' -tgInst 'SERVERNAME' -tgDb 'PROD_DB_01' -tgmpdir 'DirectoryDetails' -ForceTerminateConnection -RetainBackups 1 -trunclog $false –mgmt standard

 

 

So instead of creating database PROD_DB_01 the snap manager restored database with name PROD_DB__Clone on it's own.

 

The command mentioned above is scheduled through sql agent job to avoid any manual intervention. 

 

Can somebody help with the same to resolve the issue of wrong database creation with completely different name even when we pass the name of database through command only.

1 ACCEPTED SOLUTION

Mayur_Shelke

This was resolved. Somehow the delete-clone step was missed and the new clones were created with different as the clone name specified was already existing.

View solution in original post

1 REPLY 1

Mayur_Shelke

This was resolved. Somehow the delete-clone step was missed and the new clones were created with different as the clone name specified was already existing.

View solution in original post

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public