The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Data Backup and Recovery

Error: VDS disk object not found.

waynehapu

Hi Everyone,

I have an issue where when creating LUNs from Windows hosts in SQL Cluster using Snapdrive we get the following error in Snapdrive console.

"Disk Create operation on server - xxxxxxxxxx failed for reason - VDS disk object for the LUN s/n 'W-XKBZbvf7eK' has not been found"

I have a workaround for this but i would not expect this to be the acceptable behaviour of Snapdrive. Can anyone advise me on how i can fix this. I want to hand over the creation of LUNs to the Windows Server team as they do not ordinarilly allow non Windows Sys-Admins to have administrator accounts on their servers (they have given my account local admin access on servers). However, until i can get this issue sorted I cannot honestly pass this onto to the Windows admins to do. Thanks in advance.

Details of our environment:

~ Windows Server 2008 R2

~ MS SQL 2008 cluster (x3 nodes)

~ SnapManager for SQL 5.0

~ Snapdrive 6.3

~ ONtapDSM 3.4.5 (MPIO)

~ Data ONtap 7.3.5 run on filers

~ FC protocol

I have attached the screenshot of error but the text format is below.

###Windows Application Event Log entry###

Log Name: Application

Source: SnapDrive

Date: 1/04/2011 4:28:41 PM

Event ID: 1115

Task Category: LUN event

Level: Error

Keywords: Classic

User: N/A

Computer: xxxewscl202.DETNSW.WIN

Description:

Failed to create LUN of size 153600 MB. Failure in retrieving cluster information.

LUN Name = lun_upebpper03_cntdata2

Storage Path = /vol/xxxewscl200_upebpper03_cntdata2/qt_upebpper03_cntdata2/

Protocol Type = LUN

Storage System Name = xxxuc02.sanu.mgmt.det

Requested Mount Point = N:\CNTData2\

Assigned Mount Point =

Error code : VDS disk object for the LUN s/n 'W-XKBZbxHFW5' has not been found

Event Xml:

<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">

<System>

<Provider Name="SnapDrive" />

<EventID Qualifiers="49156">1115</EventID>

<Level>2</Level>

<Task>6</Task>

<Keywords>0x80000000000000</Keywords>

<TimeCreated SystemTime="2011-04-01T05:28:41.000000000Z" />

<EventRecordID>444979</EventRecordID>

<Channel>Application</Channel>

<Computer>xxxewscl202.DETNSW.WIN</Computer>

<Security />

</System>

<EventData>

<Data>lun_upebpper03_cntdata2</Data>

<Data>/vol/xxxewscl200_upebpper03_cntdata2/qt_upebpper03_cntdata2/</Data>

<Data>LUN</Data>

<Data>xxxuc02.sanu.mgmt.det</Data>

<Data>N:\CNTData2\</Data>

<Data>

</Data>

<Data>VDS disk object for the LUN s/n 'W-XKBZbxHFW5' has not been found

</Data>

<Data>153600</Data>

<Data>Failure in retrieving cluster information</Data>

</EventData>

</Event>

2 REPLIES 2

john_copeland

I have this issue too.

What was your workaround?

manuelf

check if

http://support.microsoft.com/kb/931300

is installed

Check MPIO config and If there are Virus scanners interfering.

this is in general a Microsoft issue

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public