The transition to NetApp MS Azure AD B2C is complete. If you missed the pre-registration, you will be invited to reigister at next log in.
Please note that access to your NetApp data may take up to 1 hour.
To learn more, read the FAQ and watch the video.
Need assistance? Complete this form and select “Registration Issue” as the Feedback Category.

Data Backup and Recovery

Installation issue SnapCreator 4.0.0c on Windows



I installed Snapcreator 4.0.0c on 64bit Windows and there was no apparent error but the installation routine did not ask me for an admin user and password. There was a short cmd line window but that disappeared before I could read what it was displaying.

snapcreator --profile setup seems to be for Linux only. How can I do this on Windows and any ideas what went wrong with the installation?






Are you sure that you selected to install the Snap Creator server?

Typically if you do not get prompted for a user and password this means that it is an agent only install.

Only the server needs the user name and password.

The command line window is a service being installed in the background - that is one way to check what has been installed.

The command to install has changed in Snap Creator 4.0. 

If you want to run the install through the comand line you run:  snapcreator.exe --setup

This is true for both Windows and UNIX.

Hope this helps!




yes I am sure. Both server and agent have been installed (see also attached print screen of the directory and the service.msc).

So the service has been installed but I wasn't asked for username/password.

I tried a snapcreator.exe --setup but nothing apparent happens. I get the command prompt back within about .5 seconds.

It should ask me for username and password here right?

The server itself is a 64bit Windows with a 64bit JRE installed.





Is this Windows 2003, 2008, or 2012?

Standard, Enterprise, Datacenter?

If you just run snapcreator.exe it should give you output with all of the options.

Does this happen, or are you just returned to the command line?

Have you tried re-downloading the software to see if it does the same thing?

We need to try and replicate the issue - I haven't had this experience in my environment.





its Windows 2012 Datacenter. Java is 64bit version:

D:\Apps\Netapp\Snap_Creator_Framework\scServer4.0.0c>java -version

java version "1.7.0_17"

Java(TM) SE Runtime Environment (build 1.7.0_17-b02)

Java HotSpot(TM) 64-Bit Server VM (build 23.7-b01, mixed mode)

I tried to reinstall but when running it with --setup I get the an error saying --setup is only for Unix system installation.

D:\Apps\Netapp\Snap_Creator_Framework\scServer4.0.0c>snapcreator.exe --setup

ERROR: The --setup option is for installation of Snap Creator on Unix systems only

snapcreator.exe by itself gives me a long list of all the options.



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner