Data Backup and Recovery

SMO 3.1/3.2 and AIX PowerHA issues



IHAC who has SMO  (currently 3.1P1) on a PowerHA 6.1 (AIX 6.1) server.

All backups work perfectly.

The issue comes when you want to restore (or even just mount a snapshot).

I think I narrowed the problem with Snapdrive.

First , we used SDU 4.2P1 (and it didn't detect the righ version of HUK and PoxwerHA with sdconfcheck)

I tried to upgrade to Snapdrive for Unix 5.0 and it's better since it detects PowerHA.

We do still have the issues, and I think it may be a problem of detecting a supported version of PowerHA and HostOS.

As you see below, sdconfcheck doesn't show the Host OS information: we should have a line with "Detected Host OS ....."

sl1105 /opt/NetApp/snapdrive # bin/sdconfcheck check

Detected PowerPC Architecture

Detected IBM AIX OS

Detected FCP on AIX

Detected   AIX JFS File System

Detected   AIX JFS2 File System

Detected   AIX Native LVM

Detected   AIX Native MPIO

Detected   PowerHA6.1

Detected   FCP AIX Host Utilities 5.1

Detected   iSCSI AIX Host Utilities 5.1

Did not find any supported configurations by SDU Version 5.0

sl1105 /opt/NetApp/snapdrive # oslevel

When you do a backup mount or a restore in SMO, some snapdrive commands are run. I tried to run them outside of SMO and I get this:

/usr/sbin/snapdrive snap connect -fs /sl2105/oracle/OWPPPA/ora /opt/Ontap/smo/mnt/-sl2105-oracle-OWPPPA-ora-20120220113618248_0 -snapname n6240-2A:/vol/vol_2105_2_OWPPA_data:smo_owpppa_nohacmp_owpppa_f_h_1_4028fae9359a51af01359a51b2ca0001_0 -autorename -noreserve -prefixfv SnapManager_20120220113618326

connecting vgorajdeFRppd:

        LUN copy qt_2105_1_OWPPA_data01/2105_1_OWPPA_data01.lun_0 ... created

                 (original: n6240-1a:/vol/vol_2105_1_OWPPA_data/qt_2105_1_OWPPA_data01/2105_1_OWPPA_data01.lun)

        LUN copy qt_2105_1_OWPPA_data02/2105_1_OWPPA_data02.lun_0 ... created

                 (original: n6240-1a:/vol/vol_2105_1_OWPPA_data/qt_2105_1_OWPPA_data02/2105_1_OWPPA_data02.lun)



        mapping new lun(s) ... done

        discovering new lun(s) ... done

        Importing vgorajdeFRppd_0

        Cleaning up ...

deleting disk group vgorajdeFRppd_0

         - hostvol vgorajdeFRppd_0/lvoraowpp_0 ... deleted

         - dg vgorajdeFRppd_0 ... deleted

         - LUN n6240-1a:/vol/vol_2105_1_OWPPA_data/qt_2105_1_OWPPA_data01/2105_1_OWPPA_data01.lun_0 ... deleted

         - LUN n6240-1a:/vol/vol_2105_1_OWPPA_data/qt_2105_1_OWPPA_data02/2105_1_OWPPA_data02.lun_0 ... deleted


0001-034 Command error: mount failed: mount: /dev/lvoraowpp_0 on /opt/Ontap/smo/mnt/-sl2105-oracle-OWPPPA-ora-20120220113618248_0

Cannot mount guarded filesystem.

The filesystem is potentially mounted on another node.


Finally, another command shows there is a problem detecting that there is a PowerHA configuration:

sl2105 /opt/NetApp/snapdrive # snapdrive config check cluster

0002-028 Admin error: Host OS is not supported for -devicetype shared operations.

Is this happening because it doesn't detect Host OS ?

Anyone has an idea of what is wrong in configuration in AIX/PowerHA/PowerVM ?

Thank you





the reason why it was not working is the customer configured the HACMP cluster in concurrent mode.


View solution in original post




the reason why it was not working is the customer configured the HACMP cluster in concurrent mode.


View solution in original post

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner