Data Backup and Recovery

SMSQL, cDoT and Snapvault restores

colin_graham

I am trying to setup SMSQL and snapvault intergration on CDOT 

 

When running a SMSQL backup job that also archives off to secondary storage - the job runs, and the snapshots do get sent to the SV destination as expected.

 

However - the snapvault datasets do not show up in the gui to be able to be restored.

 

Looking in the backup logs shows the following:

 

SMSQL7.2.2, Snapdrive 7.1.4 and DOT9.1

 

 

[14:36:15.861] [GH950] No database associated with an enabled data set archive backup was selected.
[14:36:15.877] [GH950] Starting to prepare the list of volumes (which has snapvault relationship) and corresponding storage details
[14:36:15.877] [GH950] Preparation of list of volumes (which has snapvault relationship) and corresponding storage details succeeded
[14:36:15.877] [GH950] Starting to transfer the snapshot on secondary
[14:36:16.298] [GH950] Starting to initiate SnapVault update ...
[14:36:18.654] [GH950] SnapVault update of snapshot from primary to secondary initiated successfully
[14:36:18.669] [GH950] Starting to write snapvault info SIF 
[14:36:18.669] [GH950] Prepare to save sanpvault info to SnapInfo file...

[14:36:18.669] [GH950] Updating snapvault info in SIF for databases sharing same drive letter - [#1]
[14:36:18.685] [GH950] Starting to find UUID for each primary snapshot to its corresponding secondaries....
[14:36:18.841] [GH950] Finding UUID for each primary snapshot to its corresponding secondaries – successful
[14:36:18.841] [GH950] Starting to find UUID for each primary snapshot to its corresponding secondaries....
[14:36:18.888] [GH950] Finding UUID for each primary snapshot to its corresponding secondaries – successful
[14:36:18.888] [GH950] Writing snapvault info SIF - completed successfully
[14:36:18.903] [GH950] Not to update SnapMirror after operation. Skip SMVI metadata transform also.
[14:36:19.668] [GH950] SDDatasetDFMProxy failed.
[14:36:19.668] [GH950] [SDAPI Error]: DFM is not configured.

106
[14:36:19.839] [GH950] Preparing LUN 'E:\', for SDAPI operation...
[14:36:20.354] [GH950] Preparing LUN 'F:\', for SDAPI operation...

[14:36:20.963] [GH950] Querying backup data sets for LUN: E...
[14:36:21.197] [GH950] Getting Snapmirror Destinations....
[14:36:24.535] [GH950] CSmSDSnapShot::GetAllSnapshotList -> Snapshot Listing failed.
[14:36:24.551] [GH950] [SDAPI Communication Exception]: Error 0xc0040457 occured. Description is not found.
[14:36:26.906] [GH950] CSmSDSnapShot::GetAllSnapshotList -> Snapshot Listing failed.
[14:36:26.922] [GH950] [SDAPI Communication Exception]: Error 0xc0040457 occured. Description is not found.

 

 

Anyone else encountered this?

Thanks

 

1 REPLY 1

duanebachi

Hello,

 

I am wondering if you figured out the solution to this issue as I am troubleshooting a similar issue. Thanks.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public