Data Backup and Recovery

Snapcreator fails on DB2 server in VMware



We have been using snapcreator 3.4 on a Windows 2003 server with DB2 v8 and snapdrive 6.3 for months with no problems.  The server is a physical server, but we plan to virtualize it in VMware next weekend.  I already have an identical clone of the server virtualized to test with in order to ensure everything will work properly.  When testing snapcreator everything seems to work but it won't take the snapshot.  When I look in the logs, I see this:

[Thu Sep 27 10:41:43 2012] Running snapshot create command ["D:/Program Files/NetApp/SnapDrive/sdcli" snap create -m cdctops1-tmp -s cdctops1-tmp-daily_20120927104110 -D G: H: I: J: K: -u no] failed with exit code [3840] and message [Initializing...CDCTOPS1-TMP : Checking policies

Any thoughts on why I'm seeing this error and how to resolve?  When I installed snap drive, I did configure it to work with vmware and was able to connect to the drives using snapdrive.  The drives are flexclones from snapshot that are not split from their parents though.  I had figured, SC shouldn't care since I'm just running through this for the test.





As further information, when I run the sdcli command from the command line, I receive this output:

Initializing...CDCTOPS1-TMP : Checking policies

CDCTOPS1-TMP : Checking access control

CDCTOPS1-TMP : Ready to create snapshot copy

Unable to create a Snapshot of a LUN.

Error: The requested operation is not supported.


Ok, I figured out my problem.  I was attempting to do my testing on flexclone's from snaps derived from production.  I assumed that since I could snap the sdw volumes in system manger, that snapdrive would be fine with it too.  I decided to perform a split on the volumes.  After I did that, all worked as expected.  If anyone has anything I should be aware of concerning DB2 and snapcreator 3.4 in a virtual environment, please let me know.




As long as you stick with RDMs and keep database backup separate from VM you will be in good shape

We are working on solutions to bring VM and DB backup together but honestly right now there is nothing really on market that does a good job but this is just my recommendation.




Good to know.  Thanks for the input Keith.  I think all is good then.



This is a SnapDrive error not a SnapCreator error

VMs are tricky especially if you are using virtual disks, I dont think SnapDrive can backup virtual disks but you would have to check IMT for what it supports.

You could use SC to backup the VM or VSC and then just forget about SnapDrive. SC if you go that route can do a federated backup where it uses vmwware plugin (vibe) to take vmware snapshot, then quiesces you app in VM, and then takes netapp snapshot. As long as app is installed in VM and not using virtual disks this should work.

Another option is go RDM and just backup the app separately from VM, this is recommended best practice.

Using virtual disks while nice for management is a nightmare to try and backup unfortunately.



NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner