Data Backup and Recovery

VSC 4 missing VAAI and getting no VMs for aligned/not aligned

fletch2007

When will VAAI plugin be available ? The release notes say "coming soon"

And the alignment detection is returning no VMs found although my datastores are full of 95% aligned VMs

32 REPLIES 32

fletch2007

Ok, I believe I've satisfied all the requirements to get VSC 4 to show me my unaligned VMs (ESXi 5.1, OnTap 8.1.1, VAAI NFS .vib, rebooted etc)

But I still see no VMs in the folders:

I will open a case with Netapp

JANDREWARTHA

See the earlier message:

"First, I'd like to make sure that folks understand there is no relationship between the Online Alignment feature in VSC 4.0 and the VAAI plugin for NAS. We are expecting to post the NFS VAAI plugin soon. Note that the first release supports requires Data ONTAP 8.1 running in cluster mode; NFS VAAI support for 7-mode is expected to be available in Data ONTAP 8.1.1.

The online alignment feature in VSC 4.0 supports VMFS datastores only"

dburkland

As others have said the online alignment tool is only available for VMFS.

In regards to VAAI, have you enabled it on the filer by running the "options nfs.vstorage.enable" command?

fletch2007

Will online alignment eventually be supported for NFS datastores?

Yes we have the setting on

nfs.vstorage.enable      on

Cloning a VM was no faster with VAAI - which operations are accelerated with VAAI on NFS?

thanks

nick_walford

Great article here http://www.virtuallanger.com/2011/12/06/vaai-is-this-thing-on/ including how to determine if VAAI is actually doing anything.

He fixed it for me 😉

fletch2007

Thanks for the link  - I checked all the VAAI boxes and cloned a VM on NFS datastore - no esxtop VAAI counters moved

In fact, you can see the NFS counters are '-' instead of zero -

@that1guynick commented 11 months ago "doing some deep testing of NFS VAAI offload that will be supported in the next (8.1) release of DataONTAP coming soon!"

Well I guess that schedule slipped - we are on 8.1.1 and still no NFS VAAI support? (even though the NFS datastore is listed as "supported" in vCenter)

fletch2007

Case No. 2003630236

BGOMBERG1

I just had a 3240 installed and it is running 8.1.1. I am running vSphere 5.0 and I have installed the NFS plugin via vmware update manager. The plugin installed successfully however my NFS data store is still show hardware acceleration is "not supported". What am I missing here? Do I have to run the install via the VSC?

D_BEREZENKO

In the knowledge base there is steps for NetApp VAAI plugin installation (VSC 4 should be installed). Do not forget to reboot your hosts.

fletch2007

There are 2 pieces to install  - VSC 4 and the more recently released NFS VAAI plugin (which is not installed via update manager, but a manual .vib download to your vCenter, then rename the file...just follow the PDF doc off the link below, and you will need to reboot the ESXi host per the doc)

Download the NetApp NFS Plug-in for VMware VAAI:

  1. a)  Go to the Software Downloads page at support.netapp.com/NOW/cgi-bin/software.
  2. b)  Scroll down and click NetApp NFS Plug-in for VMware VAAI.
  3. c)  Select the ESXi platform.
  4. d)  Download either the offline bundle (.zip) or online bundle (.vib) of the most recent plug-in.

I tried cloning a VM and VAAI was obviously not involved - the IO still went through the ESXi host.

Linked clones are supposed to be faster?  Still trying to find the Netapp doc describing the NFS operations for vmware that VAAI benefits.

JANDREWARTHA

Did you reboot your hosts?

BGOMBERG1

The remediation process reboots them automatically. It seems however that I just answered my own question. I followed these instructions  https://kb.netapp.com/support/index?page=content&id=3013414 installed via the VSC tools menu and refreshed the datastore. It is now "supported". The install processes through the VSC updates the firewall policies and option values which seemed to do the trick. I am now worried about the installation I performed via update manager and if I perhaps should not have done that?

D_BEREZENKO

Does NFS VAAI Plugin supporting VMWare ESXi 5.0 and ONTAP 7-Mode?

In the knowledge base there is steps only for 4.0. Pay attention to the right apper corner "Incompatible ESX/ESXi hosts are not selectable".

JANDREWARTHA

Are your filers running 8.1.1 7-Mode? Until you upgrade them, the VM hosts will be greyed out, but once you do they become enabled (or at least they did for me).

D_BEREZENKO

Yes, I notice. It did the work when I updated my Filers to 8.1.1

After reboot  Hardware Acceleration shows Supported

fletch2007

I upgraded to 8.1.1 and I've got my NFS datastore showing Hardware Acceleration Supported

So which operations can I now expect to be offloaded to the Netapp controller?

thanks

PS: and when can we get the NFS non-disruptive alignment supported?

RICCO4400

Hi everyboby

Anton, may I ask you, if your problem was solved?

I'm facing the same problem ""No controllers found" in the Provisioning and Cloning tab"

Monitoriing et host tab is correct

I see my FAS2040

But error message as you get

Optimization and mogration tab works well (I can see my VM and align vmdk

But Protection tab not working, I see my vCenter datacenter en cluster, but NO entities (datastore or VM) are NOT shown

Config is: vCenter where VSC 4.0 is installed = Windows 2008R2 SP1

FAS2040 HA Ontap 8.1

Thanks for your input

Cheers

Isa

ericw

The NFS VAAI plugin is now available on the NOW site.

BREDEMANN

Is this version of the plugin only supported by Cluster mode?  What version of ONTAP is required?  It does not look like 8.1.1, 7-mode is out.

ericw

This version supports Cluster mode. It is also expected to support 7-mode when the 7-mode support is available in 8.1.1.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public