Data Backup and Recovery

scf-00074

Vlad

i'm getting erros on clean up with suggestion to increase the WRAPPER_TIMEOUT_IN_MSEC value in agent.properties and couldn't find much information on what' the supported range?
the current value is 3600000..

 

 

Thanks

-Vlad

9 REPLIES 9

gert_leunis

Hi,

 

Where you able to solve the issue?

 

Thanks!

 

Kind regards...

mailers12

We have the same problem with the hana plug-in: SCF-00074: Cleanup for plug-in [hana] failed with error [null] and exit code [1], Exiting!

Any one any idee?

subhayan

Hello Everyone, I understand this is one of the older posts. We have seen the same behaviour in one of our boxes. Did anyone of you actually manage to fix it?

 

[2016-08-28 23:56:22,409] INFO: Performing cleanup on : oracle
[2016-08-28 23:56:27,543] ERROR: [ngzadwdb02-stg:9090 (4.1.1.1)] Operation failed. Verify that plugins/wrapper/wrapper binary has execute permission set. Increase the WRAPPER_TIMEOUT_IN_MSEC value in agent.properties if operations require more time to complete.
[2016-08-28 23:56:27,544] ERROR: [ngzadwdb02-stg:9090(4.1.1.1)] SCF-00074: Cleanup for plug-in [oracle] failed with error [null] and exit code [102], Exiting!

lcoppitelli

Got the same problem

 

WRAPPER_TIMEOUT_IN_MSEC is set to 288000000 msec (80 Hours)

 

#cat agent.properties | grep -i wrap
WRAPPER_TIMEOUT_IN_MSEC=288000000

 

But the process timeouts after just 5 minutes.

 

########## Application cleanup ##########
[2015-07-06 00:05:35,764] INFO: Performing cleanup on : oracle
[2015-07-06 00:05:40,897] ERROR: [xxx:9090 (4.1.1.1)] Operation failed. Verify that plugins/wrapper/wrapper binary has execute permission set. Increase the WRAPPER_TIMEOUT_IN_MSEC value in agent.properties if operations require more time to complete.
[2015-07-06 00:05:40,897] ERROR: [xxx:9090(4.1.1.1)] SCF-00074: Cleanup for plug-in [oracle] failed with error [null] and exit code [102], Exiting!
########## Agent Workflow Finalization ##########

 

 

no entry for SCF-00074 on the admin guide either

marcel_juhnke

Hi, in this case it nothing to do with the configured wrapper timeout in the Agent config.

 

I found that the same error message is thrown if the SC_AGENT_TIMEOUT is reached, which by default is set to 300 seconds (your 5 minutes). So you want to set this value higher first.

 

But usually Quiescing & Unquiescing an Oracle DB should not take any longer than that.

 

Regards

Marcel

lcoppitelli

@marcel_juhnke

Thank you for your input, unfortunately, SC_AGENT_TIMEOUT on the server side was already set to 3600s (1h) as well...

marcel_juhnke

Sorry, you're right. I meant SC_AGENT_UNQUIESCE_TIMEOUT actually, which is 305 by default.

lcoppitelli

Even that, its already set to 3605 😞

 

 

########################################################################################################################
#     Agent Options                                                                                                    #
########################################################################################################################
SC_AGENT_UNQUIESCE_TIMEOUT=3605
SC_AGENT_WATCHDOG_ENABLE=N
SC_AGENT=
SC_AGENT_LOG_ENABLE=Y
SC_AGENT_TIMEOUT=3600

 

amarnatr

WRAPPER_TIMEOUT_IN_MSEC is used when SCF Agent is communicating with the plugin.

 

This value is internally represented as a int. So its max value is 2^31-1. (2 power 31)

 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public