Network and Storage Protocols

Mount a CIFS share on Unix server?

netappmagic

A volume would have to be exported from a filer, and then be mounted on a Unix (Linux) server. However, if we install a service for NFS on a Window server, it could be mounted on Windows as well.

My question is, is there any way similar to mount NFS share on window, I can mount a CIFS share on a Linux server? If there is, how do I do that? any documented steps?

Thanks in advance for your help!

7 REPLIES 7

sharmadevender

Here are the steps.

1.) Check for cifs-util package.

[root@dev-linux ~]# rpm -qa | grep -i cifs-util

cifs-utils-5.4-1.fc17.x86_64

if cifs-util package doesnot exist, install it.

2.) create a cifs share on NetApp appliance.

> cifs shares -add share1 /vol/test

> cifs shares

share1       /vol/test
                        everyone / Full Control

3.) Mount share1 to linux.

[root@dev-linux ~]# mount -t cifs 192.168.234.5:/share1 /mnt -o username=administrator
Password:


once you enter this command it will ask you for administrator password {created during cifs setup}.

4.) Validate mount point

[root@dev-linux /]# df -h /mnt
Filesystem             Size  Used Avail Use% Mounted on
192.168.234.5:/share1  809M  138M  672M  18% /mnt

Hope it will help

-DEV

Hi DEV,

your message seems very informational. However, I am having problems to install the rpm package. Have you encountered the same error? maybe you can quickly point out where is the problem is?

# rpm -ivh /tmp/cifs-utils-5.4-1.fc17.x86_64.rpm

warning: /tmp/cifs-utils-5.4-1.fc17.x86_64.rpm: Header V3 RSA/SHA256 signature: NOKEY, key ID 1aca3465

error: Failed dependencies:

        keyutils is needed by cifs-utils-5.4-1.fc17.x86_64

        libc.so.6(GLIBC_2.14)(64bit) is needed by cifs-utils-5.4-1.fc17.x86_64

        libcap-ng.so.0()(64bit) is needed by cifs-utils-5.4-1.fc17.x86_64

        libtalloc.so.2()(64bit) is needed by cifs-utils-5.4-1.fc17.x86_64

        libtalloc.so.2(TALLOC_2.0.2)(64bit) is needed by cifs-utils-5.4-1.fc17.x86_64

        libwbclient.so.0()(64bit) is needed by cifs-utils-5.4-1.fc17.x86_64

        rpmlib(FileDigests) <= 4.6.0-1 is needed by cifs-utils-5.4-1.fc17.x86_64

        rpmlib(PayloadIsXz) <= 5.2-1 is needed by cifs-utils-5.4-1.fc17.x86_64

PBANHOLZER

have you already solved your problem?

what kind of Linux /  Unix do you have? In a Debian System you would use "apt-get install cifs-utils" - same on Ubuntu systems. In a RedHat system you would use "yum install cifs-utils" and after successful installation the mount command as shown. (If you're using SLES just use Yast for installation)

KSV

try on the linux server and see if this helps

 

mount -t cifs -o username=USERNAME,password=PASSWORD,domain=ABC //Server/Share  /mnt/Share

 

 

These are the dependencies, which is required by cifs-util package. for eg

it says "keyutils is needed by cifs-utils-5.4-1.fc17.x86_64". You need to install Keyutils rpm first before installing cifs-util and so on for other dependencies.

sharmadevender

Use NFS client for windows..

Your answer seems not for my question.

I am asking for mounting CFS shares on Unix server

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public