Network and Storage Protocols

Windows 10 SMB 2 and SMB 3 mising shares

TimothyPWilson

On the ONTAP 8.2 we have enabled SMB 2 and SMB 3 and set signing required to false. On Windows 10 we set the registry to:

      • HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters\AllowInsecureGuestAuth = 1

 

When we use SMB 1 and disable SMB 2 and SMB 3 to connect to the CIFS shares we are fine. When we remove SMB 1 and enable SMB 2 and SMB 3, we get sporadic drive mappings from CIFS.

 

I am in the process of verifying my WAN accelerators to ensure SMB is set for 2 and 3 althogh I doubt this is the error since some share mount.

 

We are having a hard time understanding why we can connect with SMB 1 and see all the shares from a VSERVER but using SMB 2 and SMB 3 we only see certain shares.

 

Any ideas?

 

Thanks

3 REPLIES 3

JamesIlderton

We've seen similar behavior due to some limitations in Cisco's WAAS related to SMB.  I eblieve the latest versions support SMB3 better, but we had to bypass some of the acceleration due to this and some older hardware at sites we haven't refreshed yet.  Here's some Cisco release notes that discuss the newer functionality:

 

http://www.cisco.com/c/en/us/td/docs/app_ntwk_services/waas/waas/v611/note/waas611xrn.html#pgfId-90802

 

And here's some screenshots one of my network admin shared of our config speficially related to this issue:

 

waas1.jpg

 

 

waas2.jpg

 

 

waas3.jpg

 

Hope that helps!

 

We will give it a try. Thanks

kman2123

Did you get this resolved? 

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public