Network and Storage Protocols

Windows Server 2012 and SMB2

radek_kubka

Hi all,

I am playing with ONTAP Simulator 8.1.1 & Windows Server 2012.

All the settings on the NetApp side were default, so SMB2 was enabled. Every attempt to access a CIFS share  from w2k12 led to the server reboot. I now disabled SMB2 (options cifs.smb2.enable off) & everything works like a charm.

Is it something specific to simulator maybe, or does w2k12 'dislike' SMB2 on ONTAP (8.1.1)?

Regards,

Radek

1 ACCEPTED SOLUTION

radek_kubka

OK, bingo!

Just found this: http://support.microsoft.com/kb/2686098

Setting "options cifs.smb2.signing.reqiured on" solves the issue & now the server talks happily to the simulator over SMB2.1

View solution in original post

2 REPLIES 2

radek_kubka

OK, bingo!

Just found this: http://support.microsoft.com/kb/2686098

Setting "options cifs.smb2.signing.reqiured on" solves the issue & now the server talks happily to the simulator over SMB2.1

View solution in original post

Does doing this have any impact on older SMB clients: Windows 7, XP, OSX Snow Leopard or Lion/Mountain Lion?

-Andrew

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public