ONTAP Hardware

Cannot assign disk



I have this message on my FAS2040 when I try to take ownership of one disk.

diskown.releasingMismatchedReservation:warning]: ownership calculation is releasing reservation on disk 0c.00.5 (S/N 612345679812345XNX) as it is owned by unowned (ID 123456798)

diskown.StealingDiskPrevented:warning]: Ownership for disk 0d.01.0 (S/N HBD6786) cannot be changed because system  (ID 12346598) currently owns the persistent reservation.

How can I fix this?






If there is still an old system ID owning the disk and cannot unassign it from that system anymore, try this:

priv set diag

disk assign <disk-id> -s unowned -f

If the disks still have a reservation on them, you will need to remove that with "storage release disks" (I think this one is only available in maintenance mode or takeover mode).

Best regards


Hi All

I have just come across this issue as well. Scenario: Had a couple of Clustered ONTAP nodes that we needed to re-purpose. The idea was to go to maintenance mode and remove all disk ownership and then just assign the disks.

However I had the message "ownership calculation is releasing reservation on disk " A disk show -n showed all disks as unowned but any attempt to own them would result in a message telling me that the disk was owned by another.

Following Franja.Schmid info above, I took the chance to firstly power off the shelves and head and then power them back on. Problem Solved

Hope this helps


had the same issue:

localhost:diskown.ownerReservationMismatch:warning]: disk 3a.01.23 (S/N LXWLAJXM) is supposed to be owned by this node but has a persistent reservation placed by node ?? (ID xxxxxx)

it was a new cluster installation and instead of changing/rewiring the heads I reset everything


ha-config modify controller non-ha

ha-config modify chassis non-ha

mailbox destroy local

mailbox destroy partner

loader> setenv partner-sysid ""


power off head & shelf

power on shelf & head


loader> setenv partner-sysid SYSID



ha-config modify controller ha

ha-config modify chassis ha

"disk show" showed no more errors and maybe the power off/on would have been enough...



>disk remove_ownership <disk_id>

If that doesen't do it, then,
>disk assign <disk_id> -f

You also might need to go to advanced mode before issuing those commands. >priv set advanced.

>priv set will simply bring you back to normal mode.

Do you know where that disk came from?

I mean, if it's not a empty one and there is a part of aggregate in it, and you assign it to your filer, you will get a warning message. Aggregate in degraded mode, or something like that, so don't panic, you just have to destroy it then



Have you tried to unassign it on current owner first?

NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner