ONTAP Hardware

FAS2240 queries wrong DNS Servers

Wat

Hello everyone,

 

I'm dealing with a pair of FAS2240s in HA configuration. I have a need to decommission a couple of DNS servers, so I updated the /etc/resolv.conf to point to new DNS servers, but they're still querying the original servers for remotesupportagent.netapp.com about once a minute. I want to be certain that they're querying the new designated DNS servers prior to removing the old ones, can anyone help me figure out why they refuse to query the new servers?

 

Both FAS2240's have had their /etc/resolv.conf updated, and I've tried toggling 'options dns.enable off/on'. Can't seem to get them to just start querying the new servers. Any help would be greatly appreciated. Thanks!

-Wat

1 ACCEPTED SOLUTION

robinpeter

Interesting...,

 

Seems like you have done everything to update the DNS entry on a 7-Mode system.

 

https://library.netapp.com/ecmdocs/ECMP1155586/html/GUID-386E0B02-3B7F-4DAD-ACCE-35E9A2CA36AE.html

 

it might be holding on to the the connection which is already established. Should clear things up after a takeover-giveback (which is silly)

 

Or

 

Try disconnectig the old DNS servers from network for a shot time.. to see the controller pickup the new DNS servers.

 

NetApp is not supporting RSA anymore... you should consider using Autosupport on Demand

by enabling ASUP via HTTPS as recommended by NetApp.

RSA should be the reason your controller's SP trying to reach https://remotesupportagent.netapp.com port 443

 

Robin.

View solution in original post

4 REPLIES 4

robinpeter

Interesting...,

 

Seems like you have done everything to update the DNS entry on a 7-Mode system.

 

https://library.netapp.com/ecmdocs/ECMP1155586/html/GUID-386E0B02-3B7F-4DAD-ACCE-35E9A2CA36AE.html

 

it might be holding on to the the connection which is already established. Should clear things up after a takeover-giveback (which is silly)

 

Or

 

Try disconnectig the old DNS servers from network for a shot time.. to see the controller pickup the new DNS servers.

 

NetApp is not supporting RSA anymore... you should consider using Autosupport on Demand

by enabling ASUP via HTTPS as recommended by NetApp.

RSA should be the reason your controller's SP trying to reach https://remotesupportagent.netapp.com port 443

 

Robin.

View solution in original post

andris

Yes, the Remote Support Diagnostics Tool and the Remote Support Agent component of it on the Service Processors is no longer functional.

See: End of Life: Remote Support Diagnostics Tool (RSDT) and Remote Support Enterprise (RSE)

 

You should definitely disable the RSA feature on all of your Service Processors to save bandwidth and SP CPU cycles.

See: https://kb.netapp.com/support/s/article/ka31A00000012fX/data-ontap-remote-support-evolution-how-to-enable-aod-and-disable-rsdt

 

 

Wat

Thank you so much! A simple takeover/giveback fixed it immediately!

robinpeter

Thank You,

 

Glad it worked out.

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public