ONTAP Hardware

SP upgrade - unzip failed

rozle_palcar

Hello,

We have to upgrade SP modules on V3210 HA system at customer. Since machine is in takeover mode I can't upgrade both SP modules over DOT, so I have to use 'sp update <link>' command from SP prompt. When I execute command I get error about unzip:

SP netapp2> sp update http://www.osap.si/tmp/308-02139_A0_1.3_SP_FW.tar.gz

Downloading package...

Uncompressing package...

FW package unzip failed.....FAILED

Cleaning up...

ERROR : SP FW Update Unsuccessful.

I tried to upload firmware package on FTP with few different clients (in case problem would be corrupted file) but it is the same. Also I tried to upgrade to lower versions of SP but I receive the same error... For files with *.zip extension it reports that file-type is not correct.

Probably there is problem because version of SP module is ancient (1.0.1) but that does not change the fact that I have to upgrade it

SP netapp2> sp status

Firmware Version:     1.0.1

Mgmt MAC Address:     00:A0:98:13:C0:2C


Do you have any idea how could I upgrade SP module over http? Thank you in advance!

Best regards,

Rozle

2 REPLIES 2

mharding

Hello - Did you check the Upgrade Guides from the support site - they address Service Processor upgrades?  If that doesn't help, and if you're not getting an answer, try opening a support ticket. 

BISHTECHIT

Hello -

Try this

[copy SP update file to NAS -> etc$ -> software ...rename to SP_FW.zip]

Run ---

software install SP_FW.zip

sp update

...

sp status

Announcements
NetApp on Discord Image

We're on Discord, are you?

Live Chat, Watch Parties, and More!

Explore Banner

Meet Explore, NetApp’s digital sales platform

Engage digitally throughout the sales process, from product discovery to configuration, and handle all your post-purchase needs.

NetApp Insights to Action
I2A Banner
Public